summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore1
-rwxr-xr-x[-rw-r--r--]PKGBUILD6
-rw-r--r--nvchecker.toml4
3 files changed, 8 insertions, 3 deletions
diff --git a/.gitignore b/.gitignore
index 8a5cafba2b8e..4b62e7679d6f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,3 +3,4 @@
!/PKGBUILD
!/.SRCINFO
!/*.install
+!/nvchecker.toml
diff --git a/PKGBUILD b/PKGBUILD
index 5512e2367c4c..353316f28844 100644..100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
+#!/usr/bin/env -S sh -c 'nvchecker -cnvchecker.toml --logger=json | jq -r '\''.version | sub("^v"; "") | split("-") | .[-1]'\'' | xargs -i{} sed -i "s/^\\(pkgver=\\).*/\\1{}/" $0'
# shellcheck shell=bash disable=SC2034,SC2154
-# Maintainer: Wu Zhenyu <wuzhenyu@ustc.edu>
-
+# ex: nowrap
pkgname=stardict-ecdict
pkgver=1.0.28
pkgrel=2
@@ -8,7 +8,7 @@ pkgdesc="Free English to Chinese Dictionary Database"
arch=(any)
url=https://github.com/skywind3000/ECDICT
license=(GPL3)
-source=("$url/releases/download/$pkgver/ecdict-stardict-28.zip")
+source=("$url/releases/download/$pkgver/ecdict-stardict-${pkgver##*.}.zip")
sha256sums=('c707d0f3ded6ec79b96466da4a1574e074703da5af9c120fbad97f9cb08c6f2c')
package() {
diff --git a/nvchecker.toml b/nvchecker.toml
new file mode 100644
index 000000000000..8b42f79b4fb7
--- /dev/null
+++ b/nvchecker.toml
@@ -0,0 +1,4 @@
+[stardict-ecdict]
+source = "github"
+github = "skywind3000/ECDICT"
+use_latest_release = true