summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e38bdb46b4f9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = stear-keyboard-git
+ pkgdesc = Simple remote keyboard
+ pkgver = 0.1
+ pkgrel = 2
+ url = https://gitlab.gnome.org/tallero/stear-keyboard
+ arch = any
+ license = AGPL3
+ depends = python-appdirs
+ depends = python-keyboard
+ depends = python-gnupg
+ depends = python-setproctitle
+ provides = stear-keyboard
+ conflicts = stear-keyboard
+ source = git+https://gitlab.gnome.org/tallero/stear-keyboard
+ sha512sums = SKIP
+
+pkgname = stear-keyboard-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b37549b2d493
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Pellegrino Prevete <pellegrinoprevete@gmail.com>
+
+_pkgname=stear-keyboard
+pkgname=$_pkgname-git
+pkgver=0.1
+pkgrel=2
+pkgdesc="Simple remote keyboard"
+arch=('any')
+url="https://gitlab.gnome.org/tallero/stear-keyboard"
+license=(AGPL3)
+depends=(python-appdirs python-keyboard python-gnupg python-setproctitle)
+source=("git+https://gitlab.gnome.org/tallero/$_pkgname")
+conflicts=("stear-keyboard")
+provides=("stear-keyboard")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git describe --tags | sed 's/-/+/g'
+}
+
+package() {
+ cd $_pkgname
+ python3 setup.py install --root="${pkgdir}" --optimize=1
+}