summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD77
-rw-r--r--steelstorm-dedicated.desktop10
-rw-r--r--steelstorm-dedicated.sh4
-rw-r--r--steelstorm.desktop10
-rw-r--r--steelstorm.install7
-rw-r--r--steelstorm.sh4
7 files changed, 147 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2fa6fee24568
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+pkgbase = steelstorm2-hib
+ pkgdesc = a classic top down shooter, rife with explosions and things to explode, with a distinct visual style (version included in Humble Indie Bundle No 3)
+ pkgver = 2.00.02818
+ pkgrel = 10000
+ epoch = 4
+ url = http://www.steel-storm.com/
+ install = steelstorm.install
+ arch = i686
+ arch = x86_64
+ license = commercial
+ depends = curl
+ depends = sdl_image
+ depends = sdl_ttf
+ depends = sdl_mixer
+ depends = libvorbis
+ depends = libogg
+ depends = libmodplug
+ depends = freetype2
+ conflicts = steelstorm2
+ conflicts = steelstorm
+ conflicts = steelstorm-beta
+ replaces = steelstorm
+ source = steelstorm-br-2.00.02818-release.tar.gz::hib://steelstorm-br-2.00.02818-release.tar.gz
+ source = steelstorm.desktop
+ source = steelstorm.sh
+ source = steelstorm-dedicated.desktop
+ source = steelstorm-dedicated.sh
+ md5sums = dc3e88ac4efd12e88037af140aa803ca
+ md5sums = 21848d410d35f60f227cc8cf662251e4
+ md5sums = 73d596ac67fb34ebc28df1f89b789dc2
+ md5sums = 1ec8024f637b9608732c3d9b72dba226
+ md5sums = 565ec1b72aff78bd2e311c289b65e2d5
+
+pkgname = steelstorm2-hib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..96772c998ed9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,77 @@
+# Inspired by wido's steelstorm (episode 1) pkgbuild
+# Contributor: barraponto
+# Maintainer: Jose Riha <jose1711 gmail com>
+
+pkgname=steelstorm2-hib
+_pkgname=steelstorm
+pkgver=2.00.02818
+epoch=4
+pkgrel=10000
+url="http://www.steel-storm.com/"
+pkgdesc="a classic top down shooter, rife with explosions and things to explode, with a distinct visual style (version included in Humble Indie Bundle No 3)"
+arch=('i686' 'x86_64')
+license=('commercial')
+install=${_pkgname}.install
+depends=('curl' 'sdl_image' 'sdl_ttf' 'sdl_mixer' 'libvorbis' 'libogg' 'libmodplug' 'freetype2')
+replaces=('steelstorm')
+
+DLAGENTS+=('hib::/usr/bin/echo "Could not find %u. Manually download it to \"$(pwd)\", or set up a hib:// DLAGENT in /etc/makepkg.conf."; exit 1')
+_gamepkg="steelstorm-br-${pkgver}-release.tar.gz"
+
+source=("$_gamepkg::hib://$_gamepkg"
+ steelstorm.desktop
+ steelstorm.sh
+ steelstorm-dedicated.desktop
+ steelstorm-dedicated.sh)
+conflicts=('steelstorm2' 'steelstorm' 'steelstorm-beta')
+
+md5sums=('47a70084ec01f3fc5c20f8ff76a687fe'
+ '21848d410d35f60f227cc8cf662251e4'
+ '73d596ac67fb34ebc28df1f89b789dc2'
+ '1ec8024f637b9608732c3d9b72dba226'
+ '565ec1b72aff78bd2e311c289b65e2d5')
+
+build() {
+true
+}
+
+package() {
+ cd ${srcdir}
+
+ cd ${_pkgname}
+ mkdir -p ${pkgdir}/opt/
+
+ cp -r ${srcdir}/${_pkgname} ${pkgdir}/opt/
+
+ if [ "${CARCH}" = "x86_64" ]; then
+ # Delete bin 32 bits
+ rm ${pkgdir}/opt/${_pkgname}/${_pkgname} ${pkgdir}/opt/${_pkgname}/${_pkgname}-dedicated
+ install -Dm 755 ${pkgdir}/opt/${_pkgname}/${_pkgname}64 ${pkgdir}/opt/${_pkgname}/${_pkgname}
+ install -Dm 755 ${pkgdir}/opt/${_pkgname}/${_pkgname}64-dedicated ${pkgdir}/opt/${_pkgname}/${_pkgname}-dedicated
+
+ elif [ "${CARCH}" = "i686" ]; then
+ # Delete bin 64 bits
+ rm ${pkgdir}/opt/${_pkgname}/${_pkgname}64 ${pkgdir}/opt/${_pkgname}/${_pkgname}64-dedicated
+ chmod 0755 ${pkgdir}/opt/${_pkgname}/${_pkgname}
+ chmod 0755 ${pkgdir}/opt/${_pkgname}/${_pkgname}-dedicated
+
+ else
+
+ echo "If you're not running x86_64 or i686, how are you running Arch?"
+ return 1
+ fi
+
+ # Install .desktop, icon, license and bin
+ install -Dm 644 ${srcdir}/steelstorm.desktop ${pkgdir}/usr/share/applications/steelstorm.desktop
+ install -Dm 755 ${srcdir}/steelstorm.sh $pkgdir/usr/bin/steelstorm
+ install -Dm 644 ${srcdir}/steelstorm-dedicated.desktop ${pkgdir}/usr/share/applications/steelstorm-dedicated.desktop
+ install -Dm 755 ${srcdir}/steelstorm-dedicated.sh $pkgdir/usr/bin/steelstorm-dedicated
+
+ install -Dm 644 ${pkgdir}/opt/${_pkgname}/icons/ss_ep2_icon_64.png ${pkgdir}/usr/share/pixmaps/steelstorm.png
+ install -Dm 644 ${pkgdir}/opt/${_pkgname}/license.txt ${pkgdir}/usr/share/licenses/license.txt
+}
+md5sums=('dc3e88ac4efd12e88037af140aa803ca'
+ '21848d410d35f60f227cc8cf662251e4'
+ '73d596ac67fb34ebc28df1f89b789dc2'
+ '1ec8024f637b9608732c3d9b72dba226'
+ '565ec1b72aff78bd2e311c289b65e2d5')
diff --git a/steelstorm-dedicated.desktop b/steelstorm-dedicated.desktop
new file mode 100644
index 000000000000..61e3a9c49fb8
--- /dev/null
+++ b/steelstorm-dedicated.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=Steel Storm Episode 2 (Dedicated)
+GenericName=a classic top down shooter, rife with explosions and things to explode, with a distinct visual style.
+TryExec=steelstorm-dedicated
+Exec=steelstorm-dedicated
+Icon=steelstorm
+Categories=Application;Game;
+StartupNotify=true
diff --git a/steelstorm-dedicated.sh b/steelstorm-dedicated.sh
new file mode 100644
index 000000000000..6997ea88278f
--- /dev/null
+++ b/steelstorm-dedicated.sh
@@ -0,0 +1,4 @@
+#!/bin/bash
+
+cd /opt/steelstorm/
+./steelstorm-dedicated $*
diff --git a/steelstorm.desktop b/steelstorm.desktop
new file mode 100644
index 000000000000..5f6218d97103
--- /dev/null
+++ b/steelstorm.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=Steel Storm Episode 2
+GenericName=a classic top down shooter, rife with explosions and things to explode, with a distinct visual style.
+TryExec=steelstorm
+Exec=steelstorm
+Icon=steelstorm
+Categories=Application;Game;
+StartupNotify=true
diff --git a/steelstorm.install b/steelstorm.install
new file mode 100644
index 000000000000..7ea3cf21c2dc
--- /dev/null
+++ b/steelstorm.install
@@ -0,0 +1,7 @@
+post_install() {
+ cat <<- EOF
+ IF YOU HAD EPISODE 1 version 1.00.01723 or earlier version, THE PROGRESS
+ WILL NOT BE PASSED to Steel Storm: Burning Retribution. Please delete all
+ user data from \$HOME/.steelstorm
+ EOF
+}
diff --git a/steelstorm.sh b/steelstorm.sh
new file mode 100644
index 000000000000..4d1baa7f2f60
--- /dev/null
+++ b/steelstorm.sh
@@ -0,0 +1,4 @@
+#!/bin/bash
+
+cd /opt/steelstorm/
+./steelstorm $*