summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 97ab8dc6885c..d186a3e96b74 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = stegify
pkgdesc = Tool for LSB steganography written in Go
pkgver = 1.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/DimitarPetrov/stegify
arch = x86_64
license = MIT
@@ -11,4 +11,3 @@ pkgbase = stegify
sha512sums = a2b0ff8dbe6d6f06d4239446b25fe149df15ea3d995cd2dad48130834c25faaffb1142f72e45bc50ad6d5e38cc48fb9f5652ec7dd6d796f67f33cdef13ada661
pkgname = stegify
-
diff --git a/PKGBUILD b/PKGBUILD
index 162672870a1f..140c0532e1d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=stegify
pkgdesc="Tool for LSB steganography written in Go"
pkgver=1.2
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url="https://github.com/DimitarPetrov/stegify"
license=('MIT')
@@ -20,7 +20,8 @@ build() {
export CGO_CXXFLAGS="${CXXFLAGS}"
export CGO_LDFLAGS="${LDFLAGS}"
export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
- go get -d ./...
+ go mod init github.com/DimitarPetrov/stegify
+ go get github.com/DimitarPetrov/stegify/steg
go build -o "$pkgname" .
}