summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
-rw-r--r--stegsnow.patch120
3 files changed, 163 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..51e1ff183c65
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = stegsnow
+ pkgdesc = The program SNOW is used to conceal messages in ASCII text by appending whitespace to the end of lines.
+ pkgver = 20130616
+ pkgrel = 1
+ url = http://www.darkside.com.au/snow/
+ arch = any
+ license = Apache 2.0
+ provides = stegsnow
+ source = git+https://anonscm.debian.org/git/collab-maint/stegsnow.git
+ source = stegsnow.patch
+ md5sums = SKIP
+ md5sums = 3fc8c6e36aec935e1c5c2ff4ab428500
+
+pkgname = stegsnow
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..432cd6cda753
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+pkgname=stegsnow
+pkgver='20130616'
+pkgrel=1
+pkgdesc="The program SNOW is used to conceal messages in ASCII text by appending whitespace to the end of lines."
+url="http://www.darkside.com.au/snow/"
+license=('Apache 2.0')
+arch=('any')
+provides=('stegsnow')
+source=(
+ git+"https://anonscm.debian.org/git/collab-maint/stegsnow.git"
+ "stegsnow.patch"
+)
+md5sums=(
+ "SKIP"
+ "3fc8c6e36aec935e1c5c2ff4ab428500"
+)
+
+build() {
+ cd "$srcdir/stegsnow"
+ git apply "../stegsnow.patch"
+ make
+}
+
+package() {
+ cd "$srcdir/stegsnow"
+ install -D -m755 "stegsnow" "$pkgdir/usr/bin/stegsnow"
+ install -D -m644 "stegsnow.1" "$pkgdir/usr/share/man/man1/stegsnow.1"
+}
diff --git a/stegsnow.patch b/stegsnow.patch
new file mode 100644
index 000000000000..327781f07aad
--- /dev/null
+++ b/stegsnow.patch
@@ -0,0 +1,120 @@
+From 7da9659c131ab2d8b95d7a0dace8f5da41f371f8 Mon Sep 17 00:00:00 2001
+From: Oscar Latorre <oscarlatorre7896@gmail.com>
+Date: Fri, 19 Jan 2018 02:42:45 +0100
+Subject: [PATCH] Renamed to stegsnow
+
+---
+ Makefile | 2 +-
+ snow.1 => stegsnow.1 | 24 ++++++++++++------------
+ 2 files changed, 13 insertions(+), 13 deletions(-)
+ rename snow.1 => stegsnow.1 (84%)
+
+diff --git a/Makefile b/Makefile
+index 1fcc80d..90c17e8 100644
+--- a/Makefile
++++ b/Makefile
+@@ -18,7 +18,7 @@ CFLAGS ?= -O
+
+ OBJ = main.o encrypt.o ice.o compress.o encode.o
+
+-snow: $(OBJ)
++stegsnow: $(OBJ)
+ $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -o $@ $(OBJ)
+
+ clean:
+diff --git a/snow.1 b/stegsnow.1
+similarity index 84%
+rename from snow.1
+rename to stegsnow.1
+index c754bdd..f35f808 100644
+--- a/snow.1
++++ b/stegsnow.1
+@@ -1,8 +1,8 @@
+-.TH SNOW 1 "28 Dec 1996" "Version 1.1"
++.TH STEGSNOW 1 "28 Dec 1996" "Version 1.1"
+ .SH NAME
+-snow \- whitespace steganography program
++stegsnow \- whitespace steganography program
+ .SH SYNOPSIS
+-.B snow
++.B stegsnow
+ [
+ .B -CQS
+ ] [
+@@ -31,7 +31,7 @@ snow \- whitespace steganography program
+ .I outfile
+ ]]
+ .SH DESCRIPTION
+-\fBsnow\fP is a program for concealing messages in text files
++\fBstegsnow\fP is a program for concealing messages in text files
+ by appending tabs and spaces on the end of lines, and for
+ extracting messages from files containing hidden messages.
+ Tabs and spaces are invisible to most text viewers, hence the
+@@ -48,7 +48,7 @@ The start of the data is indicated by an appended tab character, which
+ allows the insertion of mail and news headers without corrupting
+ the data.
+ .PP
+-\fBsnow\fP provides rudimentary compression, using Huffman tables
++\fBstegsnow\fP provides rudimentary compression, using Huffman tables
+ optimised for English text. However, if the data is not text, or if
+ there is a lot of data, the use of the built-in compression is not
+ recommended, since an external compression program such as
+@@ -61,11 +61,11 @@ key size, passwords of any length up to 1170 characters are supported
+ are supported).
+ .PP
+ If a message string or message file are specified on the command-line,
+-\fBsnow\fP will attempt to conceal the message in the file \fIinfile\fP
++\fBstegsnow\fP will attempt to conceal the message in the file \fIinfile\fP
+ if specified, or standard input otherwise. The resulting file will be
+ written to \fIoutfile\fP if specified, or standard output if not.
+ .PP
+-If no message string is provided, \fBsnow\fP attempts to extract a
++If no message string is provided, \fBstegsnow\fP attempts to extract a
+ message from the input file. The result is written to the output file
+ or standard output.
+ .SH OPTIONS
+@@ -77,7 +77,7 @@ Compress the data if concealing, or uncompress it if extracting.
+ The contents of this file will be concealed in the input text file.
+ .TP
+ \fB-l\fP \fIline-len\fP
+-When appending whitespace, \fBsnow\fP will always produce lines shorter
++When appending whitespace, \fBstegsnow\fP will always produce lines shorter
+ than this value. By default it is set to 80.
+ .TP
+ \fB-m\fP \fImessage-string\fP
+@@ -109,13 +109,13 @@ file \fIinfile\fP, with compression, and encrypted with the password
+ "hello world". The resulting text will be stored in \fIoutfile\fP.
+ .PP
+ .RS
+-\fBsnow \-C \-m "I am lying" \-p "hello world" infile outfile\fP
++\fBstegsnow \-C \-m "I am lying" \-p "hello world" infile outfile\fP
+ .RE
+ .PP
+ To extract the message, the command would be
+ .PP
+ .RS
+-\fBsnow \-C \-p "hello world" outfile\fP
++\fBstegsnow \-C \-p "hello world" outfile\fP
+ .RE
+ .PP
+ Note that the resulting message will not be terminated by a newline.
+@@ -125,14 +125,14 @@ be indented by mail or news readers, a line length of 72 or less can
+ be used.
+ .PP
+ .RS
+-\fBsnow \-C \-l 72 \-m "I am lying" infile outfile\fP
++\fBstegsnow \-C \-l 72 \-m "I am lying" infile outfile\fP
+ .RE
+ .PP
+ The approximate storage capacity of a file can be determined with
+ the \fB-S\fP option.
+ .PP
+ .RS
+-\fBsnow \-S \-l 72 infile\fP
++\fBstegsnow \-S \-l 72 infile\fP
+ .RE
+ .SH AUTHOR
+ This application was written by Matthew Kwan, who can be reached at
+--
+2.15.1
+