summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--Makefile.patch11
-rw-r--r--PKGBUILD32
4 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..20ad98720be5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Tue Nov 1 13:12:42 UTC 2016
+pkgbase = stl2ngc-git
+ pkgdesc = converts an STL file to LinuxCNC compatible G-Code.
+ pkgver = 18.273f1cc
+ pkgrel = 1
+ url = https://github.com/koppi/stl2ngc
+ arch = x86_64
+ license = unknown
+ depends = opencamlib-git
+ source = stl2ngc-git::git://github.com/koppi/stl2ngc.git
+ source = Makefile.patch
+ md5sums = SKIP
+ md5sums = 39a6145d878c3b93f7162945d186a72a
+
+pkgname = stl2ngc-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..677c87252990
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.tar.xz
+stl2ngc-git/
diff --git a/Makefile.patch b/Makefile.patch
new file mode 100644
index 000000000000..91e3482b588a
--- /dev/null
+++ b/Makefile.patch
@@ -0,0 +1,11 @@
+diff --git a/Makefile b/Makefile
+index 9a3941d..91015b1 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,5 +1,5 @@
+ CXXFLAGS+=-Wall -O3 -fopenmp -std=gnu++11
+-LDFLAGS +=-L/usr/local/lib/opencamlib
++LDFLAGS +=-L/usr/lib/opencamlib
+ LDLIBS +=-locl
+
+ all: stl2ngc
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..15c9675b92e1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Grey Christoforo <first name at last name dot net>
+pkgname=stl2ngc-git
+pkgver=18.273f1cc
+pkgrel=1
+pkgdesc="converts an STL file to LinuxCNC compatible G-Code."
+arch=('x86_64')
+url="https://github.com/koppi/stl2ngc"
+license=('unknown')
+depends=('opencamlib-git')
+source=('stl2ngc-git::git://github.com/koppi/stl2ngc.git' Makefile.patch)
+md5sums=('SKIP'
+ '39a6145d878c3b93f7162945d186a72a')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+prepare() {
+ cd "${srcdir}/${pkgname}"
+ patch -Np1 -i ../Makefile.patch
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname}"
+ install -D -t ${pkgdir}/usr/bin stl2ngc
+}