summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD47
3 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..65b513439464
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = stone-phaser-git
+ pkgdesc = A classic analog phaser effect LADSPA, LV2 and VST2 plugin (git version)
+ pkgver = 0.1.0.r10.geaa1787
+ pkgrel = 1
+ url = https://github.com/jpcima/stone-phaser
+ arch = i686
+ arch = x86_64
+ groups = pro-audio
+ groups = ladspa-plugins
+ groups = lv2-plugins
+ groups = vst-plugins
+ license = Boost
+ makedepends = git
+ makedepends = mesa
+ depends = cairo
+ provides = stone-phaser
+ provides = stone-phaser=0.1.0
+ conflicts = stone-phaser
+ source = stone-phaser::git+https://github.com/jpcima/stone-phaser.git
+ source = dpf::git+https://github.com/DISTRHO/DPF.git
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = stone-phaser-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f04d7fedf559
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+dpf/
+stone-phaser/
+pkg/
+src/
+.AURINFO
+stone-phaser-git-*.tar.xz
+stone-phaser-git-*.src.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..87ef81f81efb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
+
+_pkgname=stone-phaser
+pkgname="${_pkgname}-git"
+pkgver=0.1.0.r10.geaa1787
+pkgrel=1
+pkgdesc="A classic analog phaser effect LADSPA, LV2 and VST2 plugin (git version)"
+arch=('i686' 'x86_64')
+url="https://github.com/jpcima/stone-phaser"
+license=('Boost')
+depends=('cairo')
+makedepends=('git' 'mesa')
+#optdepends=('mod-host: for using the MOD pedal GUI')
+groups=('pro-audio' 'ladspa-plugins' 'lv2-plugins' 'vst-plugins')
+provides=("${_pkgname}" "${_pkgname}=${pkgver//.r*/}")
+conflicts=("${_pkgname}")
+source=("${_pkgname}::git+https://github.com/jpcima/${_pkgname}.git"
+ 'dpf::git+https://github.com/DISTRHO/DPF.git')
+md5sums=('SKIP' 'SKIP')
+
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+
+ git describe --long --exclude latest | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "${srcdir}/${_pkgname}"
+
+ git submodule init
+ git config submodule.dpf.url "${srcdir}/dpf"
+ git submodule update
+
+ cd dpf
+ patch -N -r - -p 1 -i ../resources/patch/DPF-bypass.patch || return 0
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ make DESTDIR="${pkgdir}" PREFIX=/usr install
+}