summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a99f843cafd7..14aeb9e6748b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,11 @@
pkgbase = stow-cm
- pkgdesc = config manager (simple impl of gun-stow)
+ pkgdesc = config manager (gun-stow like)
pkgver = nightly
pkgrel = 1
- url = https://github.com/someoneonsmile/stow
+ url = https://github.com/someoneonsmile/stow-cm
arch = x86_64
license = GPL2
- conflicts = stow
- source = stow-cm.tar.gz::https://github.com/someoneonsmile/stow/releases/download/nightly/stow-x86_64-unknown-linux-musl.tar.gz
+ source = stow-cm.tar.gz::https://github.com/someoneonsmile/stow-cm/releases/download/nightly/stow-cm-x86_64-unknown-linux-musl.tar.gz
sha512sums = SKIP
pkgname = stow-cm
diff --git a/PKGBUILD b/PKGBUILD
index beb04fb7a012..41f4e6c63083 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
pkgname=stow-cm
pkgver=nightly
pkgrel=1
-pkgdesc="config manager (simple impl of gun-stow)"
+pkgdesc="config manager (gun-stow like)"
arch=('x86_64')
-url="https://github.com/someoneonsmile/stow"
+url="https://github.com/someoneonsmile/${pkgname}"
license=('GPL2')
# depends=('coreutils')
makedepends=()
-conflicts=('stow')
-source=("${pkgname}.tar.gz::https://github.com/someoneonsmile/stow/releases/download/nightly/stow-x86_64-unknown-linux-musl.tar.gz")
+conflicts=()
+source=("${pkgname}.tar.gz::https://github.com/someoneonsmile/${pkgname}/releases/download/nightly/${pkgname}-x86_64-unknown-linux-musl.tar.gz")
sha512sums=('SKIP')
pkgver() {
@@ -17,7 +17,7 @@ pkgver() {
}
package() {
- cd "$srcdir/stow-x86_64-unknown-linux-musl"
- install -Dm755 "stow" "$pkgdir/usr/bin/$pkgname"
+ cd "$srcdir/${pkgname}-x86_64-unknown-linux-musl"
+ install -Dm755 "${pkgname}" "$pkgdir/usr/bin/$pkgname"
install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}