summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--LICENSE23
-rw-r--r--PKGBUILD25
3 files changed, 38 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2b724e4c7a77..1bed94720d97 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,17 @@
pkgbase = strapi
- pkgdesc = Content Management Framework (headless-CMS) to build powerful API with no effort
- pkgver = 3.0.0.alpha.11.2
- pkgrel = 2
+ pkgdesc = Open source Node.js Headless CMS to easily build customisable APIs
+ pkgver = 4.2.3
+ pkgrel = 1
url = https://strapi.io
arch = any
license = MIT
- makedepends = npm>=5.0.0
- depends = nodejs>=9.0.0
- depends = mongodb>=3.4.0
+ makedepends = npm
+ depends = nodejs-lts-gallium
provides = strapi
- noextract = strapi-3.0.0-alpha.11.2.tgz
- source = https://registry.npmjs.org/strapi/-/strapi-3.0.0-alpha.11.2.tgz
+ noextract = strapi-4.2.3.tgz
+ source = https://registry.npmjs.org/@strapi/strapi/-/strapi-4.2.3.tgz
source = LICENSE
- sha512sums = 853c866cec80e137eea9e8a09921205eb5d9bc49360d63ed6d5811b40e1421327fd7ca771d83ab9dc2643aad25a7a47ea94fdabf4d8ff2f572c7c92f04652ebe
- sha512sums = 07d628c82c22ce8da740a34ad487a20972c51195180ac4cfc957f1367dd1a2b1b7d5e0d93cbaed054f3f279d0ec2e9d837301c84122dff0b9a7903e124906fde
+ sha256sums = f249ad71e2eac0a018e14f49e15d66171793e90e7782c224dd64da41a083a5ff
+ sha256sums = c9291261c888edc8fd80d24d47f507033630cf4108ca9040fc640cd95a7eea79
pkgname = strapi
-
diff --git a/LICENSE b/LICENSE
index 374bffb6c555..db018546b5eb 100644
--- a/LICENSE
+++ b/LICENSE
@@ -1,7 +1,22 @@
-Copyright (c) 2015-2018 Strapi Solutions.
+Copyright (c) 2015-present Strapi Solutions SAS
-Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:
+Portions of the Strapi software are licensed as follows:
-The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.
+* All software that resides under an "ee/" directory (the “EE Software”), if that directory exists, is licensed under the license defined in "ee/LICENSE".
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+* All software outside of the above-mentioned directories or restrictions above is available under the "MIT Expat" license as set forth below.
+
+MIT Expat License
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index ebd6ba4a9ca5..80428e31983b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,22 @@
# Maintainer: Inder Redni <inder@oad.earth>
pkgname=strapi
-pkgver=3.0.0.alpha.11.2
-_pkgver=3.0.0-alpha.11.2
-pkgrel=2
-pkgdesc="Content Management Framework (headless-CMS) to build powerful API with no effort"
+pkgver=4.2.3
+pkgrel=1
+pkgdesc="Open source Node.js Headless CMS to easily build customisable APIs"
arch=('any')
url="https://strapi.io"
license=('MIT')
-depends=('nodejs>=9.0.0' 'mongodb>=3.4.0')
-makedepends=('npm>=5.0.0')
+depends=('nodejs-lts-gallium')
+makedepends=('npm')
provides=('strapi')
-source=("https://registry.npmjs.org/$pkgname/-/$pkgname-$_pkgver.tgz"
+source=("https://registry.npmjs.org/@strapi/strapi/-/$pkgname-$pkgver.tgz"
LICENSE)
-noextract=($pkgname-$_pkgver.tgz)
-sha512sums=('853c866cec80e137eea9e8a09921205eb5d9bc49360d63ed6d5811b40e1421327fd7ca771d83ab9dc2643aad25a7a47ea94fdabf4d8ff2f572c7c92f04652ebe'
- '07d628c82c22ce8da740a34ad487a20972c51195180ac4cfc957f1367dd1a2b1b7d5e0d93cbaed054f3f279d0ec2e9d837301c84122dff0b9a7903e124906fde')
+noextract=($pkgname-$pkgver.tgz)
+sha256sums=('f249ad71e2eac0a018e14f49e15d66171793e90e7782c224dd64da41a083a5ff'
+ 'c9291261c888edc8fd80d24d47f507033630cf4108ca9040fc640cd95a7eea79')
package() {
- npm install -g --user root --prefix "$pkgdir"/usr "$srcdir"/$pkgname-$_pkgver.tgz
- rm -r "$pkgdir"/usr/etc
+ npm install -g --prefix "$pkgdir"/usr "$srcdir"/$pkgname-$pkgver.tgz
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
-
- # Fix permissions
- find "$pkgdir/usr" -type d -exec chmod 755 '{}' +
}