summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--60-streamdeck.rules3
-rw-r--r--PKGBUILD45
3 files changed, 39 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3dc32d810ebd..42b71c783918 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = streamdeck-ui-git
- pkgdesc = A Linux compatible UI for the Elgato Stream Deck
- pkgver = 3.2.0.r26.gf96faf8
+ pkgdesc = Frontend for the Elgato Stream Deck
+ pkgver = 4.1.0.r10.g6a3beb04
pkgrel = 1
url = https://github.com/streamdeck-linux-gui/streamdeck-linux-gui
arch = any
@@ -11,7 +11,9 @@ pkgbase = streamdeck-ui-git
makedepends = python-poetry
makedepends = python-wheel
depends = pyside6
+ depends = python
depends = python-cairosvg
+ depends = python-evdev
depends = python-filetype
depends = python-importlib-metadata
depends = python-pillow
@@ -19,7 +21,7 @@ pkgbase = streamdeck-ui-git
depends = python-elgato-streamdeck
depends = python-pynput
optdepends = gnome-shell-extension-appindicator: tray icon support gnome-shell
- provides = streamdeck-ui
+ provides = streamdeck-ui=4.1.0
conflicts = streamdeck-ui
source = streamdeck-ui::git+https://github.com/streamdeck-linux-gui/streamdeck-linux-gui.git
source = 60-streamdeck.rules
@@ -27,7 +29,7 @@ pkgbase = streamdeck-ui-git
source = streamdeck.png
source = streamdeck.service
sha256sums = SKIP
- sha256sums = f91b76a71ee5253bcc3dff2a096fb7c2cc8ec4f510c7a9adc4df1f0967ea3dd3
+ sha256sums = cc633ad9097763b3a488efe609ce95186eeed07a8cbfc83e15869db422acbf5d
sha256sums = 745bbc947cfe4536e52721ef65db75c599903c0ab3450fbbf96c44e322e42c4c
sha256sums = 03726bef65cec1a2ff4bb0241e021d112bf8b5a9a90ca0e3ebeba34358b281fe
sha256sums = f3350b2db661c0eebd8bbe3305d81d0189aa24552c286a9302484a32845526e0
diff --git a/60-streamdeck.rules b/60-streamdeck.rules
index 6716ba74c12f..1f2476527949 100644
--- a/60-streamdeck.rules
+++ b/60-streamdeck.rules
@@ -1,3 +1,6 @@
+# Enable user access for "write text" feature on wayland
+SUBSYSTEM=="misc", KERNEL=="uinput", OPTIONS+="static_node=uinput", TAG+="uaccess"
+
SUBSYSTEM=="usb", ATTRS{idVendor}=="0fd9", ATTRS{idProduct}=="0060", TAG+="uaccess"
SUBSYSTEM=="usb", ATTRS{idVendor}=="0fd9", ATTRS{idProduct}=="0063", TAG+="uaccess"
SUBSYSTEM=="usb", ATTRS{idVendor}=="0fd9", ATTRS{idProduct}=="006c", TAG+="uaccess"
diff --git a/PKGBUILD b/PKGBUILD
index f2e9f0a04985..704c8abf7de2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,33 @@
# Maintainer: xiota / aur.chaotic.cx
# Contributor: fsyy <fossy2001 at web.de>
+## useful links
+# https://streamdeck-linux-gui.github.io/streamdeck-linux-gui/
+# https://github.com/streamdeck-linux-gui/streamdeck-linux-gui"
+
+## options
+: ${_build_git:=true}
+
+unset _pkgtype
+[[ "${_build_git::1}" == "t" ]] && _pkgtype+="-git"
+
+## basic info
_pkgname="streamdeck-ui"
-pkgname="$_pkgname-git"
-pkgver=3.2.0.r26.gf96faf8
+pkgname="$_pkgname${_pkgtype:-}"
+pkgver=4.1.0.r10.g6a3beb04
pkgrel=1
-pkgdesc="A Linux compatible UI for the Elgato Stream Deck"
-arch=('any')
-#"https://streamdeck-linux-gui.github.io/streamdeck-linux-gui/"
+pkgdesc="Frontend for the Elgato Stream Deck"
url="https://github.com/streamdeck-linux-gui/streamdeck-linux-gui"
license=('MIT')
+arch=('any')
+
+# main package
depends=(
#'python-xcffib'
'pyside6'
+ 'python'
'python-cairosvg'
+ 'python-evdev'
'python-filetype'
'python-importlib-metadata'
'python-pillow'
@@ -34,7 +48,7 @@ optdepends=(
'gnome-shell-extension-appindicator: tray icon support gnome-shell'
)
-if [ x"$pkgname" == x"$_pkgname" ] ; then
+if [ "${_build_git::1}" != "t" ] ; then
# normal package
_pkgsrc="$_pkgname"
_pkgext="tar.gz"
@@ -46,7 +60,7 @@ if [ x"$pkgname" == x"$_pkgname" ] ; then
}
else
# git package
- provides=("$_pkgname")
+ provides=("$_pkgname=${pkgver%%.r*}")
conflicts=("$_pkgname")
_pkgsrc="$_pkgname"
@@ -54,7 +68,8 @@ else
sha256sums+=('SKIP')
pkgver() {
- git -C "$_pkgsrc" describe --long --tags --exclude='*[a-zA-Z][a-zA-Z]*' \
+ cd "$_pkgsrc"
+ git describe --long --tags --abbrev=8 --exclude='*[a-zA-Z][a-zA-Z]*' \
| sed -E 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
}
fi
@@ -66,7 +81,7 @@ source+=(
"streamdeck.service"
)
sha256sums+=(
- 'f91b76a71ee5253bcc3dff2a096fb7c2cc8ec4f510c7a9adc4df1f0967ea3dd3'
+ 'cc633ad9097763b3a488efe609ce95186eeed07a8cbfc83e15869db422acbf5d'
'745bbc947cfe4536e52721ef65db75c599903c0ab3450fbbf96c44e322e42c4c'
'03726bef65cec1a2ff4bb0241e021d112bf8b5a9a90ca0e3ebeba34358b281fe'
'f3350b2db661c0eebd8bbe3305d81d0189aa24552c286a9302484a32845526e0'
@@ -79,13 +94,13 @@ build() {
package() {
cd "$_pkgsrc"
- python -m installer --destdir="${pkgdir:?}" dist/*.whl
+ python -m installer --destdir="$pkgdir" dist/*.whl
- install -Dm644 "${srcdir:?}/60-streamdeck.rules" -t "${pkgdir:?}/usr/lib/udev/rules.d/"
- install -Dm644 "${srcdir:?}/streamdeck.service" -t "${pkgdir:?}/usr/lib/systemd/user/"
+ install -Dm644 "$srcdir/60-streamdeck.rules" -t "$pkgdir/usr/lib/udev/rules.d/"
+ install -Dm644 "$srcdir/streamdeck.service" -t "$pkgdir/usr/lib/systemd/user/"
- install -Dm644 "${srcdir:?}/streamdeck-ui.desktop" -t "${pkgdir:?}/usr/share/applications/"
- install -Dm644 "${srcdir:?}/streamdeck.png" -t "${pkgdir:?}/usr/share/pixmaps/"
+ install -Dm644 "$srcdir/streamdeck-ui.desktop" -t "$pkgdir/usr/share/applications/"
+ install -Dm644 "$srcdir/streamdeck.png" -t "$pkgdir/usr/share/pixmaps/"
- install -Dm644 LICENSE -t "${pkgdir:?}/usr/share/licenses/${pkgname:?}/"
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
}