summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD23
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..749f9aeee1b9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = subdomain-analyzer
+ pkgdesc = Get full detailed information of selected domain
+ pkgver = 20150518
+ pkgrel = 1
+ url = https://github.com/El3ct71k/SubDomain-Analyzer
+ arch = any
+ license = GPL3
+ depends = python2
+ depends = python2-gevent
+ depends = python2-dnspython
+ depends = python2-prettytable
+ source = https://github.com/El3ct71k/SubDomain-Analyzer/archive/master.zip
+ md5sums = SKIP
+
+pkgname = subdomain-analyzer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6ae3072f7f3c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Alex Zose <alexander.zosimidis[at]gmail[dot]com>
+pkgname=subdomain-analyzer
+pkgver=20150518
+pkgrel=1
+pkgdesc="Get full detailed information of selected domain"
+url="https://github.com/El3ct71k/SubDomain-Analyzer"
+arch=("any")
+license=('GPL3')
+depends=('python2'
+ 'python2-gevent'
+ 'python2-dnspython'
+ 'python2-prettytable')
+source=("https://github.com/El3ct71k/SubDomain-Analyzer/archive/master.zip")
+md5sums=("SKIP")
+package() {
+ sed -i 's/python/python2/' ${srcdir}/SubDomain-Analyzer-master/subdomain-analyzer.py
+ sed -i 's/subdomains.txt/\/usr\/share\/subdomain-analyzer\/subdomains.txt/' ${srcdir}/SubDomain-Analyzer-master/subdomain-analyzer.py
+ chmod +x ${srcdir}/SubDomain-Analyzer-master/subdomain-analyzer.py
+ mkdir -p ${pkgdir}/usr/share/subdomain-analyzer
+ mkdir -p ${pkgdir}/usr/bin
+ cp ${srcdir}/SubDomain-Analyzer-master/* ${pkgdir}/usr/share/subdomain-analyzer
+ ln -s /usr/share/subdomain-analyzer/subdomain-analyzer.py ${pkgdir}/usr/bin/subdomain-analyzer
+}