summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--[-rwxr-xr-x]PKGBUILD38
2 files changed, 32 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 100959e7a36f..1350fa517377 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = surfn-icons-git
- pkgdesc = Surfn is a colourful icon theme.
- pkgver = 20.5
- pkgrel = 3
+ pkgdesc = Surfn, a colourful icon theme
+ pkgver = 9.7.1.r31.gb45e8c22
+ pkgrel = 1
+ epoch = 1
url = https://github.com/erikdubois/Surfn
arch = any
- license = Attribution-NonCommercial-ShareAlike 4.0 International Public License
+ license = custom:CC BY-NC-SA 4.0
makedepends = git
options = !strip
options = !emptydirs
diff --git a/PKGBUILD b/PKGBUILD
index 986285ab49da..3db9daf29003 100755..100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,35 @@
-# Maintainer: Erik Dubois <erik.dubois@gmail.com>
+# Maintainer: Yiyao Yu <yuydevel at protonmail dot com>
+# Contributor: Erik Dubois <erik.dubois@gmail.com>
pkgname=surfn-icons-git
-pkgver=20.5
-pkgrel=3
-_destname="/usr/share/icons/"
-pkgdesc="Surfn is a colourful icon theme."
+_pkgname=Surfn
+pkgver=9.7.1.r31.gb45e8c22
+pkgrel=1
+epoch=1
+pkgdesc='Surfn, a colourful icon theme'
arch=('any')
-url="https://github.com/erikdubois/Surfn"
-license=('Attribution-NonCommercial-ShareAlike 4.0 International Public License')
+url='https://github.com/erikdubois/Surfn'
+license=('custom:CC BY-NC-SA 4.0')
makedepends=('git')
options=(!strip !emptydirs)
source=('Surfn::git+https://github.com/erikdubois/Surfn.git')
sha256sums=('SKIP')
+pkgver() {
+ cd "${_pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
package() {
- find ${srcdir}/Surfn/surfn-icons -type f -name "*.sh" -exec chmod 644 '{}' \;
- install -dm 755 ${pkgdir}${_destname}
- cp -r ${srcdir}/Surfn/surfn-icons/* ${pkgdir}${_destname}
-} \ No newline at end of file
+ cd "${srcdir}/${_pkgname}/surfn-icons"
+
+ # Delete all build scripts
+ find . -type f -name "*.sh" -delete
+
+ install -dm 755 "${pkgdir}/usr/share/icons/"
+ cp -r * "${pkgdir}/usr/share/icons/"
+
+ install -Dm 644 "Surfn/LICENSE.txt" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set et ts=2 sw=2 tw=79: