summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD16
2 files changed, 30 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6e436441c7af
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = surfshark-wireguard
+ pkgdesc = SurfShark Wireguard Extractor
+ pkgver = 2.8
+ pkgrel = 1
+ url = https://github.com/Incognito-Coder/Wiregen.git
+ arch = x86_64
+ license = unknown
+ depends = python3
+ depends = wireguard-tools
+ provides = wiregen
+ source = git+https://github.com/Incognito-Coder/Wiregen.git
+ md5sums = SKIP
+
+pkgname = surfshark-wireguard
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a52ab5b4f27a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,16 @@
+# Maintainer: Alireza Ahmand <ahmand@vk.com>
+pkgname=surfshark-wireguard
+pkgver=2.8
+pkgrel=1
+pkgdesc="SurfShark Wireguard Extractor"
+arch=('x86_64')
+url="https://github.com/Incognito-Coder/Wiregen.git"
+license=('unknown')
+depends=('python3' 'wireguard-tools')
+provides=('wiregen')
+source=("git+$url")
+md5sums=('SKIP')
+package() {
+ cd "Wiregen"
+ sudo install -Dm755 wiregen.py "/usr/bin/wiregen"
+}