summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aeabcba95868..462870bcb5e6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = swift-language-git
pkgdesc = The Swift programming language, taken directly from the Apple repository
- pkgver = swift.DEVELOPMENT.SNAPSHOT.2023.10.28.a.r20.g7db7b21c8
+ pkgver = 2023.10.30a.r490.gb15065675
pkgrel = 1
url = https://swift.org/
arch = x86_64
@@ -44,7 +44,7 @@ pkgbase = swift-language-git
source = indexstore-db::git+https://github.com/apple/indexstore-db#branch=main
source = yams::git+https://github.com/jpsim/Yams#commit=5.0.1
source = sourcekit-lsp::git+https://github.com/apple/sourcekit-lsp#branch=main
- source = swift-asn1::git+https://github.com/apple/swift-asn1#commit=0.8.0
+ source = swift-asn1::git+https://github.com/apple/swift-asn1#commit=1.0.0
source = swift-certificates::git+https://github.com/apple/swift-certificates#commit=0.6.0
source = swift-cmark::git+https://github.com/apple/swift-cmark#branch=gfm
source = swift-docc::git+https://github.com/apple/swift-docc#branch=main
diff --git a/PKGBUILD b/PKGBUILD
index c9975f997951..53ff3e092098 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Andrew Sun <adsun701@gmail.com>
pkgname=swift-language-git
-pkgver=swift.DEVELOPMENT.SNAPSHOT.2023.10.28.a.r20.g7db7b21c8
+pkgver=2023.10.30a.r490.gb15065675
pkgrel=1
pkgdesc="The Swift programming language, taken directly from the Apple repository"
arch=('x86_64')
@@ -38,7 +38,7 @@ source=(
'indexstore-db::git+https://github.com/apple/indexstore-db#branch=main'
'yams::git+https://github.com/jpsim/Yams#commit=5.0.1'
'sourcekit-lsp::git+https://github.com/apple/sourcekit-lsp#branch=main'
- 'swift-asn1::git+https://github.com/apple/swift-asn1#commit=0.8.0'
+ 'swift-asn1::git+https://github.com/apple/swift-asn1#commit=1.0.0'
'swift-certificates::git+https://github.com/apple/swift-certificates#commit=0.6.0'
'swift-cmark::git+https://github.com/apple/swift-cmark#branch=gfm'
'swift-docc::git+https://github.com/apple/swift-docc#branch=main'
@@ -111,7 +111,7 @@ prepare () {
pkgver() {
cd "$srcdir/swift"
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long | sed -E 's/^[^0-9]+//;s/-([^0-9]+)/\1/;s/([^-]*-g)/r\1/;s/-/./g'
}
build() {