summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e88832e9ca2a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = syntha-font
+ pkgdesc = A rounded display typeface inspired by vintage synthesizer abbreviations
+ pkgver = 1.008
+ pkgrel = 1
+ url = https://www.neogrey.com/portfolio/syntha
+ arch = any
+ license = custom:FFPU
+ makedepends = hq
+ source = syntha-1.008.zip::https://dl.dafont.com/dl/?f=syntha
+ source = font-licenses.html::https://www.neogrey.com/font-licenses
+ sha256sums = 8d159c26bb3e98d186f66c1f5c02bbed93bd3c8dd7bb3dce489d1518de7442dc
+ sha256sums = SKIP
+
+pkgname = ttf-syntha
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5745074268fe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
+_font=syntha
+pkgbase=$_font-font
+pkgname=("ttf-$_font")
+pkgver=1.008
+pkgrel=1
+pkgdesc='A rounded display typeface inspired by vintage synthesizer abbreviations'
+url="https://www.neogrey.com/portfolio/$_font"
+arch=('any')
+license=('custom:FFPU')
+makedepends=('hq')
+source=("$_font-$pkgver.zip::https://dl.dafont.com/dl/?f=${_font/-/_}"
+ "font-licenses.html::https://www.neogrey.com/font-licenses")
+sha256sums=('8d159c26bb3e98d186f66c1f5c02bbed93bd3c8dd7bb3dce489d1518de7442dc'
+ 'SKIP')
+
+prepare() {
+ hq article text < font-licenses.html > FFPU.txt
+}
+
+package_ttf-syntha() {
+ install -Dm644 -t "$pkgdir/usr/share/fonts/TTF/" *.ttf
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" FFPU.txt
+}