summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a201a74bce8a..85ee37a2db90 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Mar 28 23:19:57 UTC 2016
+# Mon Mar 28 23:20:33 UTC 2016
pkgbase = systemd-kdbus
pkgver = 229
- pkgrel = 2
+ pkgrel = 3
url = http://www.freedesktop.org/wiki/Software/systemd
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 201efa843b7e..a1939d12d204 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgbase=systemd-kdbus
_pkgbase=${pkgbase%-kdbus}
pkgname=('systemd-kdbus' 'libsystemd-kdbus' 'systemd-sysvcompat-kdbus')
pkgver=229
-pkgrel=2
+pkgrel=3
arch=('i686' 'x86_64')
url="http://www.freedesktop.org/wiki/Software/systemd"
makedepends=('acl' 'cryptsetup' 'docbook-xsl' 'gperf' 'lz4' 'xz' 'pam' 'libelf'
@@ -35,11 +35,14 @@ prepare() {
git cherry-pick -n 4edc2c9b6b5b921873eb82e58719ed4d9e0d69bf
# fix assertion failure in src/core/timer.c on bootup (FS#48197)
- git cherry-pick -n 6d2353394fc33e923d1ab464c8f88df2a5105ffb
+ git cherry-pick -n 3f51aec8647fe13f4b1e46b2f75ff635403adf91
# fix udevd error checking from cg_unified() (FS#48188)
git cherry-pick -n 6d2353394fc33e923d1ab464c8f88df2a5105ffb
+ # revert "core: resolve specifier in config_parse_exec()"
+ git cherry-pick -n bd1b973fb326e9b7587494fd6108e5ded46e9163
+
./autogen.sh
}
@@ -61,7 +64,8 @@ build() {
--with-sysvrcnd-path= \
--with-ntp-servers="${timeservers[*]}"
- make
+ NPROC=$(getconf _NPROCESSORS_ONLN)
+ make -j${NPROC}
}
package_systemd-kdbus() {
@@ -72,7 +76,7 @@ package_systemd-kdbus() {
'util-linux' 'xz')
provides=('nss-myhostname' "systemd-tools=$pkgver" "udev=$pkgver")
replaces=('nss-myhostname' 'systemd-tools' 'udev')
- conflicts=('nss-myhostname' 'systemd-tools' 'udev')
+ conflicts=('systemd' 'nss-myhostname' 'systemd-tools' 'udev')
optdepends=('cryptsetup: required for encrypted block devices'
'libmicrohttpd: remote journald capabilities'
'quota-tools: kernel-level quota management'
@@ -164,7 +168,7 @@ package_systemd-sysvcompat-kdbus() {
license=('GPL2')
groups=('base')
conflicts=('sysvinit')
- depends=('systemd')
+ depends=('systemd-kdbus')
install -dm755 "$pkgdir"/usr/share/man/man8
cp -d --no-preserve=ownership,timestamp \