summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 93aac7f1b496..0a825b72dced 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,7 +9,7 @@ pkgbase = tbftss-the-pandoran-war-git
depends = sdl2_image
depends = sdl2_mixer
depends = sdl2_ttf
- source = tbftss-git::git+https://github.com/stephenjsweeney/tbftss#branch=develop
+ source = tbftss-git::git+https://github.com/stephenjsweeney/tbftss.git
sha256sums = SKIP
pkgname = tbftss-the-pandoran-war-git
diff --git a/PKGBUILD b/PKGBUILD
index 084d2b5936a6..0a22b828cb64 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,21 +8,22 @@ url="https://www.battleforthesolarsystem.com/"
arch=('x86_64')
license=('GPL2')
depends=('sdl2' 'sdl2_image' 'sdl2_mixer' 'sdl2_ttf')
-source=("${_pkgname}-git::git+https://github.com/stephenjsweeney/${_pkgname}#branch=develop")
+_srcdirectory="${_pkgname}-git"
+source=("${_srcdirectory}::git+https://github.com/stephenjsweeney/${_pkgname}.git")
sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/${_pkgname}-git"
+ cd "${srcdir}/${_srcdirectory}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "${srcdir}/${_pkgname}-git"
+ cd "${srcdir}/${_srcdirectory}"
make
}
package() {
- cd "${srcdir}/${_pkgname}-git"
+ cd "${srcdir}/${_srcdirectory}"
make DESTDIR="${pkgdir}" install
}