summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..042670de34de
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = tcl-cookfs
+ pkgdesc = cookfs file system for tcl
+ pkgver = 1.4
+ pkgrel = 4
+ url = http://www.endorser.org/en/blog/tcl/cookfs
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = tcl
+ depends = tcl
+ depends = tcl-vfs
+ depends = tcllib
+ source = https://github.com/l3iggs/tcl-cookfs/archive/1.4.tar.gz
+ md5sums = 4e9c8c2a49a0499207911bdca0801df9
+
+pkgname = tcl-cookfs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0b40f12bf842
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+pkgname=tcl-cookfs
+pkgver=1.4
+pkgrel=4
+pkgdesc="cookfs file system for tcl"
+arch=('i686' 'x86_64')
+url="http://www.endorser.org/en/blog/tcl/cookfs"
+license=('custom')
+depends=(tcl tcl-vfs tcllib)
+makedepends=(tcl)
+source=(https://github.com/l3iggs/${pkgname}/archive/${pkgver}.tar.gz)
+md5sums=('4e9c8c2a49a0499207911bdca0801df9')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir/" install
+ install -D -m644 license.terms "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}