summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD34
-rw-r--r--tcpser.1103
3 files changed, 152 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c99ddd7af3b9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = tcpser
+ pkgdesc = Jim Brain's tcpser serial to IP modem emulator (fork by FozzTexx)
+ pkgver = 1.0rc12.fz1.r27.g57d4244
+ pkgrel = 1
+ url = https://github.com/FozzTexx/tcpser
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ source = git+https://github.com/FozzTexx/tcpser#commit=57d4244ee100c9baea8f8356c4741db63796a4a2
+ source = tcpser.1
+ sha256sums = SKIP
+ sha256sums = d376440db182a0bed9d08624a008aa2cb8a00c0002b8e78316c74533de9ca46e
+
+pkgname = tcpser
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fd93bac9cc12
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+pkgname=tcpser
+pkgver=1.0rc12.fz1.r27.g57d4244
+pkgrel=1
+pkgdesc="Jim Brain's tcpser serial to IP modem emulator (fork by FozzTexx)"
+arch=(i686 x86_64)
+url="https://github.com/FozzTexx/tcpser"
+license=(GPL2)
+_commit=57d4244ee100c9baea8f8356c4741db63796a4a2
+source=("git+https://github.com/FozzTexx/tcpser#commit=$_commit"
+ "tcpser.1")
+sha256sums=('SKIP'
+ 'd376440db182a0bed9d08624a008aa2cb8a00c0002b8e78316c74533de9ca46e')
+
+pkgver() {
+ cd $pkgname
+ echo "1.0rc12.fz1.r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd $pkgname
+ make
+}
+
+package() {
+ cd $pkgname
+ install -D -m 755 tcpser "$pkgdir"/usr/bin/tcpser
+ install -D -m 644 README "$pkgdir"/usr/share/doc/$pkgname/README
+ install -D -m 644 README.md "$pkgdir"/usr/share/doc/$pkgname/README.fozztexx
+
+ cd ..
+ install -D -m 644 tcpser.1 "$pkgdir"/usr/share/man/man1/tcpser.1
+}
+
+# vim: ts=2:sw=2:et:ft=sh
diff --git a/tcpser.1 b/tcpser.1
new file mode 100644
index 000000000000..e4da41a48551
--- /dev/null
+++ b/tcpser.1
@@ -0,0 +1,103 @@
+.\" Hey, EMACS: -*- nroff -*-
+.TH TCPSER 1 "July 5, 2006"
+.SH NAME
+tcpser \- emulate a Hayes compatible modem
+.SH SYNOPSIS
+.B tcpser
+\-d \fIdev\fP \-s \fIspeed\fP [\-l \fIlog_level\fP \-t \fItracing_options\fP] ...
+.br
+.B tcpser
+\-v \fIport\fP [\-l \fIlog_level\fP \-t \fItracing_options\fP] ...
+.SH DESCRIPTION
+This manual page documents briefly the
+.B tcpser
+command.
+.PP
+\fBtcpser\fP turns a PC serial port into an emulated Hayes compatible modem that
+uses TCP/IP for incoming and outgoing connections. It can be used to allow
+older applications and systems designed for modem use to operate on the
+Internet. \fBtcpser\fP supports all standard Hayes commands, and understands
+extended and vendor proprietary commands (though it does not implement
+many of them). \fBtcpser\fP can be used for both inbound and outbound connections.
+
+.SH OPTIONS
+A summary of options is included below.
+.TP
+.B \-h
+Show summary of options.
+.TP
+.B \-p
+Port to listen on (defaults to 6400).
+.TP
+.B \-t
+Trace flags: (can be combined)
+.PD 0
+.RS 10
+.IP "s"
+modem input
+.IP "S"
+modem output
+.IP "i"
+IP input
+.IP "I"
+IP output
+.RE
+.PD 1
+.TP
+.B \-l
+Log level: 0 (NONE), 1 (FATAL) - 7 (DEBUG_X) (defaults to 0).
+.TP
+.B \-L
+Log file (defaults to stderr).
+.TP
+The following can be repeated for each modem desired (\-s, \-S, and \-i will apply to any subsequent device if not set again):
+.TP
+.B \-d
+Serial device (e.g. /dev/ttyS0). Cannot be used with \-v
+.TP
+.B \-v
+TCP port for VICE RS232 (e.g. 25232). Cannot be used with \-d
+.TP
+.B \-s
+Serial port speed (defaults to 38400).
+.TP
+.B \-S
+Speed modem will report (defaults to \-s value).
+.TP
+.B \-I
+Invert DCD pin.
+.TP
+.B \-n
+Add phone entry (number=replacement).
+.TP
+.B \-a
+Filename to send to local side upon answer.
+.TP
+.B \-A
+Filename to send to remote side upon answer.
+.TP
+.B \-c
+Filename to send to local side upon connect.
+.TP
+.B \-C
+Filename to send to remote side upon connect.
+.TP
+.B \-N
+Filename to send when no answer.
+.TP
+.B \-B
+Filename to send when modem(s) busy.
+.TP
+.B \-T
+Filename to send upon inactivity timeout.
+.TP
+.B \-i
+Modem init string (defaults to `', leave off `at' prefix when specifying).
+.TP
+.B \-D
+Direct connection (follow with hostname:port for caller, : for receiver).
+.SH AUTHOR
+tcpser was written by Jim Brain <brain@jbrain.com>.
+.PP
+This manual page was written by Peter Collingbourne <pcc03@doc.ic.ac.uk>,
+for the Debian project (but may be used by others).