summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD39
2 files changed, 29 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 187f9c57c751..1e2bb257132a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = telegram-desktop-userfonts-altscroll
- pkgdesc = Official Telegram Desktop client, with your fonts as set by fontconfig and alt scroll mechanism in media view
- pkgver = 4.15.6
- pkgrel = 2
+ pkgdesc = Official Telegram Desktop client, with changes: fonts to yours as set by fontconfig, alt scroll mechanism in media view
+ pkgver = 4.16.6
+ pkgrel = 1
url = https://desktop.telegram.org/
arch = x86_64
license = GPL3
@@ -30,7 +30,6 @@ pkgbase = telegram-desktop-userfonts-altscroll
depends = lz4
depends = minizip
depends = openal
- depends = ttf-opensans
depends = qt6-imageformats
depends = qt6-svg
depends = qt6-wayland
@@ -47,16 +46,15 @@ pkgbase = telegram-desktop-userfonts-altscroll
depends = protobuf
depends = glib2
depends = libsigc++-3.0
- depends = glibmm-2.68
depends = kcoreaddons
optdepends = webkit2gtk: embedded browser features
optdepends = xdg-desktop-portal: desktop integration
provides = telegram-desktop
conflicts = telegram-desktop
options = !debug
- source = https://github.com/telegramdesktop/tdesktop/releases/download/v4.15.6/tdesktop-4.15.6-full.tar.gz
+ source = https://github.com/telegramdesktop/tdesktop/releases/download/v4.16.6/tdesktop-4.16.6-full.tar.gz
source = mediaview-altscroll.patch
- sha512sums = 965790e34dcbb1ff84c054a0d241f9ef628ee03526c7fd6a3cb5e0d419082b495e377a55bf9aeafc03d7851077d3703fb11df497d181ddbf6699455c2945c158
+ sha512sums = 5b580d36c8b8a90981c3541d4c148df37bb7ebdec0970bfbfe4c1a9a1175e3cf41c2a14d854d7d917482aa9086ee712844ec40780741df22ad6d42fcf3c48f1f
sha512sums = 38ff8627090ac9766a8d409fa26cbd4381640e08abcb677f4524a5305d011aa0f6ce81d69313a01f0db5c1a3794805bff2a059095258f5e8d9bd1133550cca2e
pkgname = telegram-desktop-userfonts-altscroll
diff --git a/PKGBUILD b/PKGBUILD
index 2c744ed43354..a2d60e2a8668 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,50 @@
# Maintainer: detiam <dehe_tian@outlook.com>
# Contributor: Andy Kluger <https://t.me/andykluger>
+
# Upstream PKGBUILD (telegram-desktop in community repo):
# Maintainer: Sven-Hendrik Haase <svenstaro@archlinux.org>
# Contributor: hexchain <i@hexchain.org>
+
pkgname=telegram-desktop-userfonts-altscroll
-pkgver=4.15.6
-pkgrel=2
+pkgver=4.16.6
+pkgrel=1
conflicts=('telegram-desktop')
provides=('telegram-desktop')
-pkgdesc='Official Telegram Desktop client, with your fonts as set by fontconfig and alt scroll mechanism in media view'
+pkgdesc='Official Telegram Desktop client, with changes: fonts to yours as set by fontconfig, alt scroll mechanism in media view'
arch=('x86_64')
url="https://desktop.telegram.org/"
license=('GPL3')
options=('!debug')
-depends=('hunspell' 'ffmpeg' 'hicolor-icon-theme' 'lz4' 'minizip' 'openal' 'ttf-opensans'
+depends=('hunspell' 'ffmpeg' 'hicolor-icon-theme' 'lz4' 'minizip' 'openal'
'qt6-imageformats' 'qt6-svg' 'qt6-wayland' 'xxhash'
'rnnoise' 'pipewire' 'libxtst' 'libxrandr' 'libxcomposite' 'libxdamage' 'abseil-cpp' 'libdispatch'
- 'openssl' 'protobuf' 'glib2' 'libsigc++-3.0' 'glibmm-2.68' 'kcoreaddons')
+ 'openssl' 'protobuf' 'glib2' 'libsigc++-3.0' 'kcoreaddons')
makedepends=('cmake' 'git' 'ninja' 'python' 'range-v3' 'tl-expected' 'microsoft-gsl' 'meson'
'extra-cmake-modules' 'wayland-protocols' 'plasma-wayland-protocols' 'libtg_owt'
'gobject-introspection' 'boost' 'fmt' 'mm-common' 'perl-xml-parser' 'python-packaging' 'patch')
optdepends=('webkit2gtk: embedded browser features'
'xdg-desktop-portal: desktop integration')
-source=("https://github.com/telegramdesktop/tdesktop/releases/download/v${pkgver}/tdesktop-${pkgver}-full.tar.gz" 'mediaview-altscroll.patch')
-sha512sums=('965790e34dcbb1ff84c054a0d241f9ef628ee03526c7fd6a3cb5e0d419082b495e377a55bf9aeafc03d7851077d3703fb11df497d181ddbf6699455c2945c158'
+source=("https://github.com/telegramdesktop/tdesktop/releases/download/v${pkgver}/tdesktop-${pkgver}-full.tar.gz"
+ "mediaview-altscroll.patch") # https://github.com/telegramdesktop/tdesktop/pull/27245
+sha512sums=('5b580d36c8b8a90981c3541d4c148df37bb7ebdec0970bfbfe4c1a9a1175e3cf41c2a14d854d7d917482aa9086ee712844ec40780741df22ad6d42fcf3c48f1f'
'38ff8627090ac9766a8d409fa26cbd4381640e08abcb677f4524a5305d011aa0f6ce81d69313a01f0db5c1a3794805bff2a059095258f5e8d9bd1133550cca2e')
prepare() {
cd tdesktop-$pkgver-full
- for ttf in Telegram/lib_ui/fonts/*.ttf; do
- rm "$ttf"
- touch "$ttf"
+ # patching
+ for patch in "${source[@]}"; do
+ if [[ $patch == *.patch ]]; then
+ msg2 "Applying $patch"
+ patch --no-backup-if-mismatch -Np1 -i "$srcdir/$patch"
+ fi
done
- sed -i 's/DemiBold/Bold/g' Telegram/lib_ui/ui/style/style_core_font.cpp
- # https://github.com/telegramdesktop/tdesktop/pull/27245
- patch -Np1 < '../mediaview-altscroll.patch'
+ # userfonts
+ for ttf in Telegram/lib_ui/fonts/*.ttf; do
+ rm "$ttf" && touch "$ttf"
+ done && sed -i 's/DemiBold/Bold/g' \
+ Telegram/lib_ui/ui/style/style_core_custom_font.cpp
}
build() {
@@ -46,11 +54,12 @@ build() {
# https://github.com/telegramdesktop/tdesktop/blob/8fab9167beb2407c1153930ed03a4badd0c2b59f/snap/snapcraft.yaml#L87-L88
# Thanks @primeos!
cmake -B build -S tdesktop-$pkgver-full -G Ninja \
- -DCMAKE_VERBOSE_MAKEFILE=ON \
+ -DCMAKE_CXX_FLAGS=-g0 \
+ -DCMAKE_VERBOSE_MAKEFILE=OFF \
-DCMAKE_INSTALL_PREFIX="/usr" \
-DCMAKE_BUILD_TYPE=Release \
- -DTDESKTOP_API_ID=611335 \
-DDESKTOP_APP_USE_PACKAGED_FONTS=OFF \
+ -DTDESKTOP_API_ID=611335 \
-DTDESKTOP_API_HASH=d524b414d21f4d37f08684c1df41ac9c
cmake --build build
}