summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO48
-rw-r--r--PKGBUILD57
-rw-r--r--tenacity.patch17
3 files changed, 122 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e001cedbd48f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,48 @@
+pkgbase = tenacity-git
+ pkgdesc = FLOSS Audacity Fork. No telemetry, crash reports and other shenanigans like that!
+ pkgver = r19.g8733f591a
+ pkgrel = 1
+ url = https://github.com/tenacityteam/tenacity
+ arch = i686
+ arch = x86_64
+ groups = pro-audio
+ license = GPL2
+ license = CCPL
+ makedepends = git
+ makedepends = cmake
+ makedepends = clang
+ makedepends = sdl2
+ makedepends = libsoup
+ makedepends = libnotify
+ makedepends = gstreamer
+ makedepends = gst-plugins-bad-libs
+ makedepends = ffmpeg
+ makedepends = jack
+ makedepends = nasm
+ makedepends = conan
+ depends = alsa-lib
+ depends = libx11
+ depends = gtk3
+ depends = expat
+ depends = libid3tag
+ depends = libogg
+ depends = libsndfile
+ depends = libvorbis
+ depends = lilv
+ depends = lv2
+ depends = portsmf
+ depends = suil
+ depends = libmad
+ depends = twolame
+ depends = vamp-plugin-sdk
+ depends = libsoxr
+ depends = soundtouch
+ optdepends = ffmpeg: additional import/export capabilities
+ provides = audacity
+ conflicts = audacity
+ source = git+https://github.com/tenacityteam/tenacity.git
+ source = tenacity.patch
+ sha256sums = SKIP
+ sha256sums = c06c60a9ae17b9265840fcd619d2c7a5668f26a94cec80c8785c7997afd4bc96
+
+pkgname = tenacity-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cc5427e922f7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: Luke 'Darkpelz' Huckman <lukeh@outlook.my>
+# Contributor: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
+# Contributor: Ong Yong Xin <ongyongxin2020+github AT gmail DOT com>
+# Contributor: Bernhard Landauer <oberon@manjaro.org>
+# Contributor: Eric BĂ©langer <eric@archlinux.org>
+
+pkgname=tenacity-git
+pkgver=r19.g8733f591a
+pkgrel=1
+pkgdesc="FLOSS Audacity Fork. No telemetry, crash reports and other shenanigans like that!"
+arch=(i686 x86_64)
+url="https://github.com/tenacityteam/tenacity"
+license=(GPL2 CCPL)
+groups=(pro-audio)
+depends=(alsa-lib libx11 gtk3 expat libid3tag libogg libsndfile
+ libvorbis lilv lv2 portsmf suil libmad twolame vamp-plugin-sdk libsoxr soundtouch)
+makedepends=(git cmake clang sdl2 libsoup libnotify gstreamer gst-plugins-bad-libs
+ ffmpeg jack nasm conan)
+# can't find system lame portmidi
+optdepends=('ffmpeg: additional import/export capabilities')
+provides=(audacity)
+conflicts=(audacity)
+source=(
+ "git+https://github.com/tenacityteam/tenacity.git"
+ "tenacity.patch"
+)
+sha256sums=('SKIP' 'c06c60a9ae17b9265840fcd619d2c7a5668f26a94cec80c8785c7997afd4bc96')
+
+pkgver() {
+ cd tenacity
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g' | cut -d'.' -f2-
+}
+
+prepare() {
+ cd tenacity
+ patch --forward --strip=1 --input="${srcdir}/tenacity.patch"
+ touch ${srcdir}/tenacity/README.txt # missing file in upstream
+}
+
+build() {
+ mkdir tenacity/build
+ cd tenacity/build
+ CC=clang cmake \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DwxBUILD_TOOLKIT:STRING=gtk3 \
+ -Daudacity_use_wxwidgets=local \
+ audacity_use_ffmpeg:STRING=loaded \
+ ..
+ cmake --build .
+ make .
+}
+
+package() {
+ cd tenacity/build
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/tenacity.patch b/tenacity.patch
new file mode 100644
index 000000000000..643a13bf61ee
--- /dev/null
+++ b/tenacity.patch
@@ -0,0 +1,17 @@
+diff --unified --recursive --text audacity/lib-src/portaudio-v19/src/hostapi/alsa/pa_linux_alsa.c audacity.new/lib-src/portaudio-v19/src/hostapi/alsa/pa_linux_alsa.c
+--- audacity/lib-src/portaudio-v19/src/hostapi/alsa/pa_linux_alsa.c 2021-07-02 00:17:06.606660728 +0800
++++ audacity.new/lib-src/portaudio-v19/src/hostapi/alsa/pa_linux_alsa.c 2021-07-02 00:18:22.376662323 +0800
+@@ -4363,11 +4363,12 @@
+ break;
+ }
+ }
++
++ pthread_cleanup_pop( 1 );
+
+ end:
+ ; /* Hack to fix "label at end of compound statement" error caused by pthread_cleanup_pop(1) macro. */
+ /* Match pthread_cleanup_push */
+- pthread_cleanup_pop( 1 );
+
+ PA_DEBUG(( "%s: Thread %d exiting\n ", __FUNCTION__, pthread_self() ));
+ PaUnixThreading_EXIT( result );