summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 3 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 13fd45c5c4a0..a3ffaced6a17 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,13 +5,10 @@ pkgbase = terasology
epoch = 1
url = https://terasology.org
arch = x86_64
- arch = i686
license = Apache
makedepends = unzip
depends = zlib
- depends = bash
depends = java-runtime-openjdk=11
- depends = lib32-glibc
options = !strip
source = terasology
source = terasology.desktop
diff --git a/PKGBUILD b/PKGBUILD
index 120bde138ef3..0ff8dc46e285 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,11 +11,11 @@ pkgver=${_version}${_version_postfix}
pkgrel=1
epoch=1
pkgdesc="Yet another high resolution game with blocks like Minecraft!"
-arch=('x86_64' 'i686')
+arch=('x86_64')
license=('Apache')
url="https://terasology.org"
options=('!strip')
-depends=(zlib bash java-runtime-openjdk=11 lib32-glibc)
+depends=(zlib java-runtime-openjdk=11)
makedepends=('unzip')
source=(
"$pkgname"
@@ -52,7 +52,7 @@ package() {
rm Terasology.bat
rm -r natives/macosx
rm -r natives/windows
- strip -s natives/linux/libbullet-linux-amd64.so natives/linux/libbullet-linux-i686.so
+ strip -s natives/linux/libbullet-linux-amd64.so
chmod a+w "$srcdir" # Terrible permissions hack to get the game to start
cp -ra "$srcdir" "${pkgdir}/usr/share/${pkgname}"