summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO53
-rw-r--r--PKGBUILD25
-rw-r--r--texlive-installer.install29
3 files changed, 107 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f8d1cbd4f3cb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,53 @@
+pkgbase = texlive-installer
+ pkgdesc = This packages provides the installer of texlive. It also tricks Arch into thinking it has its texlive packages installed.
+ pkgver = 2018
+ pkgrel = 0
+ url = http://www.tug.org/texlive/
+ install = texlive-installer.install
+ arch = any
+ license = GPL
+ depends = wget
+ depends = xz
+ provides = texlive-bin
+ provides = texlive-bibtexextra
+ provides = texlive-core
+ provides = texlive-fontsextra
+ provides = texlive-formatsextra
+ provides = texlive-games
+ provides = texlive-humanities
+ provides = texlive-latexextra
+ provides = texlive-music
+ provides = texlive-pictures
+ provides = texlive-pstricks
+ provides = texlive-publishers
+ provides = texlive-science
+ provides = texlive-langchinese
+ provides = texlive-langcyrillic
+ provides = texlive-langextra
+ provides = texlive-langgreek
+ provides = texlive-langjapanese
+ provides = texlive-langkorean
+ conflicts = texlive-bin
+ conflicts = texlive-bibtexextra
+ conflicts = texlive-core
+ conflicts = texlive-fontsextra
+ conflicts = texlive-formatsextra
+ conflicts = texlive-games
+ conflicts = texlive-humanities
+ conflicts = texlive-latexextra
+ conflicts = texlive-music
+ conflicts = texlive-pictures
+ conflicts = texlive-pstricks
+ conflicts = texlive-publishers
+ conflicts = texlive-science
+ conflicts = texlive-langchinese
+ conflicts = texlive-langcyrillic
+ conflicts = texlive-langextra
+ conflicts = texlive-langgreek
+ conflicts = texlive-langjapanese
+ conflicts = texlive-langkorean
+ source = http://mirror.ctan.org/systems/texlive/tlnet/install-tl-unx.tar.gz
+ md5sums = SKIP
+
+pkgname = texlive-installer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a8a46840f13a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Yichao Zhou <broken.zhou@gmail.com>
+pkgname=texlive-installer
+pkgver=2018
+pkgrel=0
+pkgdesc="This packages provides the installer of texlive. It also tricks Arch into thinking it has its texlive packages installed."
+url="http://www.tug.org/texlive/"
+arch=('any')
+license=('GPL')
+depends=('wget' 'xz')
+optdepends=()
+makedepends=()
+replaces=()
+conflicts=('texlive-bin' $(pacman -Sgq texlive-most texlive-lang))
+provides=('texlive-bin' $(pacman -Sgq texlive-most texlive-lang))
+source=("http://mirror.ctan.org/systems/texlive/tlnet/install-tl-unx.tar.gz")
+md5sums=('SKIP')
+install=${pkgname}.install
+
+package() {
+ rm -r ${srcdir}/install-tl-[0-9]*/tlpkg/installer/wget
+ rm -r ${srcdir}/install-tl-[0-9]*/tlpkg/installer/xz
+
+ install -d "$pkgdir"/opt
+ cp -R ${srcdir}/install-tl-[0-9]*/ "$pkgdir"/opt/texlive-installer
+}
diff --git a/texlive-installer.install b/texlive-installer.install
new file mode 100644
index 000000000000..6e5c271885cf
--- /dev/null
+++ b/texlive-installer.install
@@ -0,0 +1,29 @@
+post_install()
+{
+ echo "======================================================================="
+ echo "This packages provides the installer of texlive. It also tricks Arch"
+ echo "into thinking it has its texlive packages installed."
+ echo "-----------------------------------------------------------------------"
+ echo "Execute"
+ echo " /opt/texlive-installer/install-tl"
+ echo "to start install texlive."
+ echo ""
+ echo "Do not remove this package after installation as this package provides"
+ echo "dependency so that Arch will not install its own texlive package."
+ echo "======================================================================="
+}
+
+post_upgrade()
+{
+ echo "======================================================================="
+ echo "This packages provides the installer of texlive. It also tricks Arch"
+ echo "into thinking it has its texlive packages installed."
+ echo "-----------------------------------------------------------------------"
+ echo "Execute"
+ echo " /opt/texlive-installer/install-tl"
+ echo "to start install texlive."
+ echo ""
+ echo "Do not remove this package after installation as this package provides"
+ echo "dependency so that Arch will not install its own texlive package."
+ echo "======================================================================="
+}