summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD103
-rw-r--r--in-source-build.diff65
3 files changed, 28 insertions, 167 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 048d90529fb5..481c6f3936bc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,33 +1,20 @@
pkgbase = textadept
pkgdesc = Fast, minimalist, and remarkably extensible cross-platform text editor
- pkgver = 11.4
- pkgrel = 5
+ pkgver = 12.0
+ pkgrel = 1
url = https://github.com/orbitalquark/textadept
arch = i686
arch = x86_64
arch = aarch64
license = MIT
- makedepends = gtk2
- makedepends = gtk3
+ makedepends = qt5-base
makedepends = ncurses
makedepends = wget
makedepends = unzip
- source = textadept-11.4.tar.gz::https://github.com/orbitalquark/textadept/archive/textadept_11.4.tar.gz
- source = in-source-build.diff
- sha256sums = fe10cbe9949e3a2ec4445ace16e26eb4b905cee2e36de76295ea9a7ca6c3aba8
- sha256sums = c6ff17408ae788108a4cd298104580b95dd09da9e3f57e360d431daee046049d
+ makedepends = cmake
+ source = https://github.com/orbitalquark/textadept/archive/textadept_12.0.tar.gz
+ sha256sums = 32722c657138a2164eadcc62feb59a3df691f6b7045fcfd7c155b9ec81cb7a5d
pkgname = textadept
- depends = gtk2
+ depends = qt5-base
depends = ncurses
-
-pkgname = textadept-gtk3
- depends = gtk3
- depends = ncurses
- provides = textadept
- conflicts = textadept
-
-pkgname = textadept-curses
- depends = ncurses
- provides = textadept
- conflicts = textadept
diff --git a/PKGBUILD b/PKGBUILD
index d006b3e265fc..a54c3f3c8e0f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,94 +1,33 @@
-# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Maintainer: TwoFinger
+# Contributor: Luis Martinez <luis dot martinez at disroot dot org>
# Contributor: Tom <reztho@archlinux.org>
# Contributor: bitwave
-pkgname=('textadept' 'textadept-gtk3' 'textadept-curses')
-pkgver=11.4
-pkgrel=5
+pkgname=textadept
+_basename=textadept
+pkgver=12.0
+pkgrel=1
pkgdesc="Fast, minimalist, and remarkably extensible cross-platform text editor"
-arch=('i686' 'x86_64' 'aarch64')
+arch=(i686 x86_64 aarch64)
url="https://github.com/orbitalquark/textadept"
-license=('MIT')
-makedepends=('gtk2' 'gtk3' 'ncurses' 'wget' 'unzip')
-source=("$pkgname-$pkgver.tar.gz::$url/archive/${pkgname}_$pkgver.tar.gz"
- in-source-build.diff)
-sha256sums=('fe10cbe9949e3a2ec4445ace16e26eb4b905cee2e36de76295ea9a7ca6c3aba8'
- 'c6ff17408ae788108a4cd298104580b95dd09da9e3f57e360d431daee046049d')
-
-prepare() {
- cd "$pkgbase-${pkgbase}_${pkgver}"
- ( cd src
- patch -p1 -i "$srcdir"/in-source-build.diff
- make deps
- ## thanks lacsaP
- sed -i '1008s/volatile//;1099s/volatile//;' scintilla/gtk/ScintillaGTKAccessible.cxx
- ## makes compile flags work again
- sed -i \
- -e 's/http:/https:/g' \
- -e 's/CFLAGS :=/CFLAGS +=/g' \
- -e 's/CXXFLAGS :=/CXXFLAGS +=/g' \
- -e 's/LDFLAGS :=/LDFLAGS +=/g' \
- Makefile )
- cp -a src src-curses
- cp -a src src-gtk3
-}
+license=(MIT)
+makedepends=(qt5-base ncurses wget unzip cmake)
+source=("$url/archive/${_basename}_$pkgver.tar.gz")
+sha256sums=(32722c657138a2164eadcc62feb59a3df691f6b7045fcfd7c155b9ec81cb7a5d)
build() {
- cd "$pkgbase-${pkgbase}_${pkgver}"
- (cd src; make GTK2=1)
- (cd src-gtk3; make)
- (cd src-curses; make curses)
+ cd "${_basename}-${_basename}_$pkgver"
+ export LDFLAGS=-Wl,-z,relro,-z,now
+ cmake -B build_dir \
+ -D CMAKE_INSTALL_PREFIX="$pkgdir"/usr \
+ -D CMAKE_BUILD_TYPE=None \
+ -D GTK2=OFF -D GTK3=OFF
+ cmake --build build_dir -j
}
package_textadept() {
- depends=('gtk2' 'ncurses')
-
- cd "$pkgbase-${pkgbase}_${pkgver}/src"
- make GTK2=1 PREFIX=/usr DESTDIR="$pkgdir" install
- rm "$pkgdir/usr/share/pixmaps/"textadept{.svg,.png}
- make curses PREFIX=/usr DESTDIR="$pkgdir" install
-
- # License
- install -dv "$pkgdir/usr/share/licenses/$pkgname/"
- ln -sv "/usr/share/$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/"
-
- # Documentation
- install -d "$pkgdir/usr/share/doc"
- ln -sv "/usr/share/$pkgname/docs" "$pkgdir/usr/share/doc/$pkgname"
-}
-
-package_textadept-gtk3() {
- depends=('gtk3' 'ncurses')
- provides=("$pkgbase")
- conflicts=("$pkgbase")
-
- cd "$pkgbase-${pkgbase}_${pkgver}/src-gtk3"
- make PREFIX=/usr DESTDIR="$pkgdir" install
- rm "$pkgdir/usr/share/pixmaps/"textadept{.svg,.png}
- make curses PREFIX=/usr DESTDIR="$pkgdir" install
-
- # License
- install -dv "$pkgdir/usr/share/licenses/$pkgname/"
- ln -sv "/usr/share/$pkgbase/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/"
-
- # Documentation
- install -dv "$pkgdir/usr/share/doc"
- ln -sv "/usr/share/$pkgbase/docs" "$pkgdir/usr/share/doc/$pkgname"
-}
-
-package_textadept-curses() {
- depends=('ncurses')
- provides=("$pkgbase")
- conflicts=("$pkgbase")
-
- cd "$pkgbase-${pkgbase}_${pkgver}/src-curses"
- make curses PREFIX=/usr DESTDIR="$pkgdir" install
-
- # License
- install -dv "$pkgdir/usr/share/licenses/$pkgname/"
- ln -sv "/usr/share/$pkgbase/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/"
+ depends=(qt5-base ncurses)
- # Documentation
- install -dv "$pkgdir/usr/share/doc"
- ln -sv "/usr/share/$pkgbase/docs" "$pkgdir/usr/share/doc/$pkgname"
+ cd "${_basename}-${_basename}_$pkgver"
+ cmake --install build_dir
}
diff --git a/in-source-build.diff b/in-source-build.diff
deleted file mode 100644
index 22de2ddd2caf..000000000000
--- a/in-source-build.diff
+++ /dev/null
@@ -1,65 +0,0 @@
---- a/Makefile 2023-02-12 11:08:23.133779767 +0800
-+++ b/Makefile 2023-02-12 11:13:08.907691463 +0800
-@@ -225,22 +225,22 @@
-
- # Executables.
-
--linux_exes := $(addprefix ../, textadept textadept-curses)
-+linux_exes := textadept textadept-curses
- win_exes := $(addprefix ../, textadept.exe textadept-curses.exe)
- osx_exes := $(addprefix ../, textadept-osx textadept-osx-curses)
-
- .PHONY: all curses win osx
- .DEFAULT_GOAL := all
- all: $(linux_exes)
--curses: ../textadept-curses
-+curses: textadept-curses
- win: $(win_exes)
- osx: $(osx_exes)
-
- # Compile natively for Linux or BSD.
-
- $(linux_exes): $(common_objs)
--../textadept: $(gui_objs)
--../textadept-curses: $(curses_objs) $(termkey_unix_objs)
-+textadept: $(gui_objs)
-+textadept-curses: $(curses_objs) $(termkey_unix_objs)
-
- ifeq (Linux, $(shell uname -s))
- $(linux_exes): CXX := g++
-@@ -252,11 +252,11 @@
- $(linux_exes): LDFLAGS += -Wl,--retain-symbols-file -Wl,$(shell pwd)/lua.sym
- endif
- ifdef GTK2
--../textadept: LDFLAGS += $(shell pkg-config --libs gtk+-2.0 gmodule-2.0)
-+textadept: LDFLAGS += $(shell pkg-config --libs gtk+-2.0 gmodule-2.0)
- else
--../textadept: LDFLAGS += $(shell pkg-config --libs gtk+-3.0 gmodule-2.0)
-+textadept: LDFLAGS += $(shell pkg-config --libs gtk+-3.0 gmodule-2.0)
- endif
--../textadept-curses: LDFLAGS += $(shell pkg-config --silence-errors --libs ncursesw || \
-+textadept-curses: LDFLAGS += $(shell pkg-config --silence-errors --libs ncursesw || \
- pkg-config --silence-errors --libs ncurses || pkg-config --silence-errors --libs curses || \
- echo -lncursesw) -lpthread
- ifeq (Linux, $(shell uname -s))
-@@ -312,9 +312,9 @@
- PIXMAPS_DIR ?= /usr/share/pixmaps
- desktop_files := $(wildcard *.desktop)
- ifeq (, $(findstring curses, $(MAKECMDGOALS)))
-- install_targets := ../textadept
-+ install_targets := textadept
- else
-- install_targets := ../textadept-curses
-+ install_targets := textadept-curses
- endif
-
- .PHONY: install uninstall
-@@ -322,7 +322,7 @@
- install -d $(DESTDIR)$(bin_dir) $(DESTDIR)$(data_dir)
- install $^ $(DESTDIR)$(data_dir)
- cp -rL $| $(DESTDIR)$(data_dir)
-- ln -s $(subst .., $(data_dir), $^) $(DESTDIR)$(bin_dir)
-+ ln -s $(data_dir)/$^ $(DESTDIR)$(bin_dir)
- if [ -d "$(XDG_DATA_DIR)" ]; then \
- install -d $(DESTDIR)$(XDG_DATA_DIR); \
- install $(desktop_files) $(DESTDIR)$(XDG_DATA_DIR); \