summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eb7d1093d41f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = textlint-rule-no-empty-section
+ pkgdesc = textlint rule not allow to create empty section.
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://github.com/azu/textlint-rule-no-empty-section
+ arch = any
+ depends = nodejs
+ depends = npm
+ noextract = textlint-rule-no-empty-section-1.1.0.tgz
+ source = http://registry.npmjs.org/textlint-rule-no-empty-section/-/textlint-rule-no-empty-section-1.1.0.tgz
+ sha1sums = 137ae6b8dfcaab759fd6068bfcc1a6c941bb4607
+
+pkgname = textlint-rule-no-empty-section
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d691755745b5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+_npmname=textlint-rule-no-empty-section
+_npmver=1.1.0
+pkgname=textlint-rule-no-empty-section # All lowercase
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="textlint rule not allow to create empty section."
+arch=(any)
+url="https://github.com/azu/textlint-rule-no-empty-section"
+license=()
+depends=('nodejs' 'npm' )
+optdepends=()
+source=(http://registry.npmjs.org/$_npmname/-/$_npmname-$_npmver.tgz)
+noextract=($_npmname-$_npmver.tgz)
+sha1sums=(137ae6b8dfcaab759fd6068bfcc1a6c941bb4607)
+
+package() {
+ cd $srcdir
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p $_npmdir
+ cd $_npmdir
+ npm install -g --prefix "$pkgdir/usr" $_npmname@$_npmver
+}
+
+# vim:set ts=2 sw=2 et: