summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD13
2 files changed, 7 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef5e294718c2..01fe93698252 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,33 +1,11 @@
pkgbase = the-deeps
pkgdesc = A text-based adventure game written in C++.
pkgver = 1.2.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/oicleevan/the-deeps
arch = any
license = MIT
- source = https://github.com/oicleevan/the-deeps/archive/refs/tags/1.2.1.zip
- sha1sums = 8e236600c6e1d0dea83da0a07d64f329a09a4215
-
-pkgname = the-deeps
-pkgbase = the-deeps
- pkgdesc = A text-based adventure game written in C++.
- pkgver = 1.2.1
- pkgrel = 1
- url = https://github.com/oicleevan/the-deeps
- arch = any
- license = MIT
- source = https://github.com/oicleevan/the-deeps/archive/refs/tags/1.2.1.zip
- sha1sums = SKIP
-
-pkgname = the-deeps
-pkgbase = the-deeps
- pkgdesc = A text-based adventure game written in C++.
- pkgver = 1.2.1
- pkgrel = 1
- url = https://github.com/oicleevan/the-deeps
- arch = any
- license = MIT
- source = https://github.com/oicleevan/the-deeps/archive/refs/tags/1.2.1.zip
+ source = the-deeps-1.2.1.tar.gz::https://github.com/oicleevan/the-deeps/archive/refs/tags/1.2.1.zip
sha256sums = d5a6fe6631f0dadc60fe06d3da6da54cb7792cdd69788b8166a65bb3cf2bc93a
pkgname = the-deeps
diff --git a/PKGBUILD b/PKGBUILD
index a91f0b5c12c4..bd46a0377c3e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,13 @@
-# This is an example PKGBUILD file. Use this as a start to creating your own,
-# and remove these comments. For more information, see 'man PKGBUILD'.
-# NOTE: Please fill out the license field for your package! If it is unknown,
-# then please put 'unknown'.
+# Contributor: Evan Oicle <oicleevan@protonmail.com>
-# Maintainer: Evan Oicle <oicleevan@protonmail.com>
pkgname=the-deeps
pkgver=1.2.1
-pkgrel=1
+pkgrel=2
pkgdesc="A text-based adventure game written in C++."
arch=('any')
url="https://github.com/oicleevan/the-deeps"
license=('MIT')
-source=("https://github.com/oicleevan/$pkgname/archive/refs/tags/$pkgver.zip")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/oicleevan/$pkgname/archive/refs/tags/$pkgver.zip")
sha256sums=('d5a6fe6631f0dadc60fe06d3da6da54cb7792cdd69788b8166a65bb3cf2bc93a')
build() {
@@ -23,5 +19,6 @@ build() {
package() {
cd "$pkgname-$pkgver"
- sudo make install
+ install -Dm755 -t "$pkgdir/usr/bin" bin/$pkgname
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE
}