summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b882adf41f51..6941f6eadcda 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = the_silver_searcher_wild-git
pkgdesc = Allen Wild's fork of ag, which supports pcre2 and .agrc user config
- pkgver = 2.2.0.r190.gc2e20d7
+ pkgver = 2.2.0.r195.gab8bbc3
pkgrel = 1
url = https://github.com/aswild/the_silver_searcher
arch = x86_64
@@ -11,6 +11,7 @@ pkgbase = the_silver_searcher_wild-git
depends = pcre2
depends = xz
depends = zlib
+ depends = libarchive
provides = the_silver_searcher
conflicts = the_silver_searcher
source = git://github.com/aswild/the_silver_searcher.git
diff --git a/PKGBUILD b/PKGBUILD
index 7d1d665b2050..ffa91f050f17 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgdesc="Allen Wild's fork of ag, which supports pcre2 and .agrc user config"
url='https://github.com/aswild/the_silver_searcher'
pkgname=the_silver_searcher_wild-git
-pkgver=2.2.0.r190.gc2e20d7
+pkgver=2.2.0.r195.gab8bbc3
pkgrel=1
provides=('the_silver_searcher')
conflicts=('the_silver_searcher')
@@ -12,7 +12,7 @@ conflicts=('the_silver_searcher')
arch=('x86_64' 'i686')
license=('Apache')
-depends=('pcre2' 'xz' 'zlib')
+depends=('pcre2' 'xz' 'zlib' 'libarchive')
makedepends=('git')
checkdepends=('python-cram')
@@ -28,7 +28,10 @@ pkgver() {
build() {
cd "$srcdir/$_srcname"
./autogen.sh
- ./configure --prefix=/usr --enable-zlib --enable-lzma \
+ ./configure --prefix=/usr \
+ --enable-zlib \
+ --enable-lzma \
+ --enable-libarchive \
ac_cv_prog_CLANG_FORMAT=no
make
}