summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD48
-rw-r--r--thefall.desktop9
-rwxr-xr-xthefall.sh4
5 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4c5f952c8915
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = thefall
+ pkgdesc = Adventure, puzzle, and side-scroller action game (requires full copy of the game)
+ pkgver = 1.5
+ pkgrel = 2
+ url = http://www.overthemoongames.com/
+ arch = i686
+ arch = x86_64
+ license = custom:commercial
+ depends = gcc-libs
+ depends = glu
+ source = TheFall_Linux_1_5.zip::hib://TheFall_Linux_1_5.zip
+ source = thefall.sh
+ source = thefall.desktop
+ md5sums = dca669c3278a3f899d3b2daede234b06
+ md5sums = 14ee5efab3c35dde029811b2807afd9b
+ md5sums = 69eb03b143b605184e1505d60e66818a
+
+pkgname = thefall
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7e2ded26cd28
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.pkg.tar*
+TheFall*.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..256db7092a1a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Ben Morgan <neembi@gmail.com>
+# Contributor: Dennis Hamester <dennis [dot] hamester [at] gmail [dot] com>
+# Contributor: J0k3r <moebius282 e4at gmail D0_T com>
+
+pkgname=thefall
+pkgver=1.5
+_pkgver=1_5
+pkgrel=2
+pkgdesc="Adventure, puzzle, and side-scroller action game (requires full copy of the game)"
+license=('custom:commercial')
+arch=('i686' 'x86_64')
+url="http://www.overthemoongames.com/"
+depends=('gcc-libs' 'glu')
+_gamepkg="TheFall_Linux_${_pkgver}.zip"
+
+# You can download the Humble Indie Bundle file manually, or you can configure
+# DLAGENTS in makepkg.conf to auto-download.
+#
+# For example, to use hib-dlagent to download files set something like this in
+# your makepkg.conf (change/add -k and add -u/-p to your needs):
+# DLAGENTS=('hib::/usr/bin/hib-dlagent -k 1a2b3c -o %o $(echo %u | cut -c 7-)')
+#
+# To auto-search through a directory containing Humble Bundle downloads, you
+# could set:
+# DLAGENTS=('hib::/usr/bin/find /path/to/downloads -name $(echo %u | cut -c 7-) -exec ln -s \{\} %o \; -quit')
+DLAGENTS+=('hib::/usr/bin/echo "Could not find %u. Download manually to \"$(pwd)\" or setup hib:// DLAGENT in /etc/makepkg.conf."; exit 1')
+
+source=("${_gamepkg}"::"hib://${_gamepkg}"
+ ${pkgname}.sh
+ ${pkgname}.desktop)
+md5sums=('dca669c3278a3f899d3b2daede234b06'
+ '14ee5efab3c35dde029811b2807afd9b'
+ '69eb03b143b605184e1505d60e66818a')
+
+package() {
+ install -dm755 "${pkgdir}/opt/${pkgname}"
+ cp -r "${srcdir}/TheFall_Data" "${pkgdir}/opt/${pkgname}/"
+ cp "${srcdir}/TheFall.x86" "${pkgdir}/opt/${pkgname}/"
+
+ # fix file permissions
+ find "${pkgdir}/opt/${pkgname}" -type d -exec chmod 755 {} +
+ find "${pkgdir}/opt/${pkgname}" -type f -exec chmod 644 {} +
+ chmod 755 "${pkgdir}/opt/${pkgname}/TheFall.x86"
+
+ install -Dm644 "${srcdir}/TheFall_Data/Resources/UnityPlayer.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -Dm755 "${srcdir}/${pkgname}.sh" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+}
diff --git a/thefall.desktop b/thefall.desktop
new file mode 100644
index 000000000000..d15458d48083
--- /dev/null
+++ b/thefall.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=The Fall
+GenericName=The Fall
+Comment=An adventure, puzzle, and side-scroller action game
+Exec=/usr/bin/thefall
+Icon=/usr/share/pixmaps/thefall.png
+Terminal=false
+Type=Application
+Categories=Game;
diff --git a/thefall.sh b/thefall.sh
new file mode 100755
index 000000000000..c55e0541e8bb
--- /dev/null
+++ b/thefall.sh
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+cd /opt/thefall
+./TheFall.x86 "$@"