summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD57
-rw-r--r--thextech-supermariobrosx-git.install12
-rw-r--r--thextech-supermariobrosx.desktop13
4 files changed, 113 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e06526920272
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = thextech-supermariobrosx-git
+ pkgdesc = The full port of the SMBX engine from VB6 into C++ and SDL2, FreeImage and MixerX, with SMBX 1.3 game assets.
+ pkgver = v1.3.r3028.g6e732ff3
+ pkgrel = 1
+ url = https://github.com/Wohlstand/TheXTech
+ install = thextech-supermariobrosx-git.install
+ arch = i386
+ arch = x86_64
+ arch = aarch64
+ license = GPLv3
+ makedepends = git
+ makedepends = cmake
+ makedepends = p7zip
+ depends = desktop-file-utils
+ depends = sdl2
+ depends = libjpeg-turbo
+ depends = libpng
+ depends = glew
+ depends = libglvnd
+ provides = thextech
+ provides = thextech-supermariobrosx
+ conflicts = thextech-supermariobrosx
+ noextract = assets.7z
+ source = git+https://github.com/Wohlstand/TheXTech
+ source = assets.7z::https://wohlsoft.ru/projects/TheXTech/_downloads/thextech-smbx13-assets-full.7z
+ source = thextech-supermariobrosx.desktop
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = f46693ed08b59d6beba12c324e5c2384a09b77b76c02dda22846ddca7e808043
+
+pkgname = thextech-supermariobrosx-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ac0b6c91c450
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: Kirikaze Chiyuki <me@chyk.ink>
+pkgname=thextech-supermariobrosx-git
+_pkgname=thextech-smbx
+pkgver=v1.3.r3028.g6e732ff3
+pkgrel=1
+pkgdesc="The full port of the SMBX engine from VB6 into C++ and SDL2, FreeImage and MixerX, with SMBX 1.3 game assets."
+arch=('i386' 'x86_64' 'aarch64')
+url="https://github.com/Wohlstand/TheXTech"
+license=('GPLv3')
+depends=('desktop-file-utils' 'sdl2' 'libjpeg-turbo' 'libpng' 'glew' 'libglvnd')
+makedepends=('git' 'cmake' 'p7zip')
+optdepends=()
+provides=('thextech' 'thextech-supermariobrosx')
+conflicts=('thextech-supermariobrosx')
+install=${pkgname}.install
+source=("git+https://github.com/Wohlstand/TheXTech"
+"assets.7z::https://wohlsoft.ru/projects/TheXTech/_downloads/thextech-smbx13-assets-full.7z"
+"thextech-supermariobrosx.desktop")
+noextract=("thextech-smbx13-assets-full.7z")
+sha256sums=("SKIP"
+"SKIP"
+"f46693ed08b59d6beba12c324e5c2384a09b77b76c02dda22846ddca7e808043")
+noextract=("assets.7z")
+
+pkgver() {
+ cd "${srcdir}/TheXTech"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g' | sed 's/lastlocal.//'
+}
+
+prepare() {
+ cd "${srcdir}/TheXTech"
+ git submodule init
+ git submodule update
+}
+
+build() {
+ env
+ cd "${srcdir}/TheXTech"
+ if [ -d build ]; then rm -rf build; fi
+ mkdir build
+ cd build
+ cmake -DCMAKE_BUILD_TYPE=MinSizeRel -DUSE_SYSTEM_LIBS=OFF -DUSE_STATIC_LIBC=ON -DPGE_SHARED_SDLMIXER=OFF -DUSE_FREEIMAGE_SYSTEM_LIBS=ON -DUSE_SYSTEM_SDL2=ON -DTHEXTECH_FIXED_ASSETS_PATH="/usr/share/games/${_pkgname}" -DTHEXTECH_USER_DIR_NAME=".${_pkgname}" ..
+ CFLAGS="-march=native -mtune=generic -O2 -pipe -fno-plt -fexceptions -Wp,-D_FORTIFY_SOURCE=2 -fstack-clash-protection -fcf-protection" CXXFLAGS="-march=native -mtune=generic -O2 -pipe -fno-plt -fexceptions -Wp,-D_FORTIFY_SOURCE=2 -fstack-clash-protection -fcf-protection -Wp,-D_GLIBCXX_ASSERTIONS" make
+}
+
+package() {
+ mkdir -p "${pkgdir}/usr/share/games/${_pkgname}"
+ 7z x "assets.7z" -o"${pkgdir}/usr/share/games/${_pkgname}"
+ mkdir -p "${pkgdir}/usr/bin"
+ install -Dm0755 "${srcdir}/TheXTech/build/output/bin/thextech" "${pkgdir}/usr/bin/${_pkgname}"
+ install -Dm0644 "${srcdir}/TheXTech/resources/icon/thextech_128.png" "${pkgdir}/usr/share/pixmaps/thextech.png"
+ mkdir -p "${pkgdir}/usr/share/"{licenses,doc}"/${pkgname/-git/}"
+ mv "${pkgdir}/usr/share/games/${_pkgname}/"*"."{odt,pdf} "${pkgdir}/usr/share/doc/${pkgname/-git/}/"
+ mv "${pkgdir}/usr/share/games/${_pkgname}/License.txt" "${pkgdir}/usr/share/licenses/${pkgname/-git/}/LICENSE"
+ mkdir -p "${pkgdir}/usr/share/applications"
+ install -Dm0755 "${pkgname/-git/}.desktop" "${pkgdir}/usr/share/applications/${pkgname/-git/}.desktop"
+}
diff --git a/thextech-supermariobrosx-git.install b/thextech-supermariobrosx-git.install
new file mode 100644
index 000000000000..4216c8360708
--- /dev/null
+++ b/thextech-supermariobrosx-git.install
@@ -0,0 +1,12 @@
+post_install() {
+ update-desktop-database -q /usr/share/applications
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+
diff --git a/thextech-supermariobrosx.desktop b/thextech-supermariobrosx.desktop
new file mode 100644
index 000000000000..4c6c18a8d678
--- /dev/null
+++ b/thextech-supermariobrosx.desktop
@@ -0,0 +1,13 @@
+[Desktop Entry]
+Name=TheXTech SMBX
+GenericName=Super Mario Bros. X
+Comment=The full port of the SMBX engine from VB6 into C++ and SDL2, FreeImage and MixerX, with SMBX 1.3 game assets.
+Encoding=UTF-8
+Version=1.3.5.3
+Type=Application
+Terminal=false
+Icon=thextech
+Exec=thextech-smbx %F
+Categories=Game;
+StartupWMClass=thextech-smbx
+