summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
-rw-r--r--thunar-vcs-plugin.install3
3 files changed, 16 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f475391c1332..37f0f38824b7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,17 @@
-# Generated by mksrcinfo v8
-# Sat Feb 4 13:09:02 UTC 2017
pkgbase = thunar-vcs-plugin
pkgdesc = SVN and GIT integration for Thunar.
- pkgver = 0.1.5
+ pkgver = 0.2.0
pkgrel = 1
- url = http://goodies.xfce.org/projects/thunar-plugins/thunar-vcs-plugin
- install = thunar-vcs-plugin.install
+ url = https://goodies.xfce.org/projects/thunar-plugins/thunar-vcs-plugin
arch = i686
arch = x86_64
license = GPL
makedepends = intltool
- depends = thunar
+ depends = thunar>=1.7.0
depends = git
depends = subversion
- depends = apr
- source = http://archive.xfce.org/src/thunar-plugins/thunar-vcs-plugin/0.1/thunar-vcs-plugin-0.1.5.tar.bz2
- source = thunar-vcs-plugin.install
- sha256sums = 7094f576865957397eefcdb1b05ba9be020a396c12949077507ea1573b1ef451
- sha256sums = 9236743ff2218aa974f15227a57a1f364744c3459a1ed94ac9a087aa2b1be3c4
+ source = https://archive.xfce.org/src/thunar-plugins/thunar-vcs-plugin/0.2/thunar-vcs-plugin-0.2.0.tar.bz2
+ sha256sums = SKIP
pkgname = thunar-vcs-plugin
diff --git a/PKGBUILD b/PKGBUILD
index 335b9799c1ee..e01b83d57c97 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,24 @@
-# Contributor: henning mueller <henning@orgizm.net>
+# Maintainer: twa022 <twa022 at gmail dot com>
pkgname=thunar-vcs-plugin
-pkgver=0.1.5
+pkgver=0.2.0
pkgrel=1
pkgdesc="SVN and GIT integration for Thunar."
-arch=(i686 x86_64)
-license=(GPL)
-url=http://goodies.xfce.org/projects/thunar-plugins/thunar-vcs-plugin
-depends=(thunar git subversion apr)
-makedepends=(intltool)
-source=(
- http://archive.xfce.org/src/thunar-plugins/thunar-vcs-plugin/0.1/$pkgname-$pkgver.tar.bz2
- $pkgname.install
-)
-install=$pkgname.install
+arch=('i686' 'x86_64')
+license=('GPL')
+url="https://goodies.xfce.org/projects/thunar-plugins/thunar-vcs-plugin"
+depends=('thunar>=1.7.0' 'git' 'subversion')
+makedepends=('intltool')
+source=("https://archive.xfce.org/src/thunar-plugins/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.bz2")
+sha256sums=('SKIP')
build() {
- cd $srcdir/$pkgname-$pkgver
+ cd "${pkgname}-${pkgver}"
./configure --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib/xfce4
make
}
package() {
- cd $srcdir/$pkgname-$pkgver
+ cd "${pkgname}-${pkgver}"
make DESTDIR=$pkgdir install
}
-
-sha256sums=('7094f576865957397eefcdb1b05ba9be020a396c12949077507ea1573b1ef451'
- '9236743ff2218aa974f15227a57a1f364744c3459a1ed94ac9a087aa2b1be3c4')
diff --git a/thunar-vcs-plugin.install b/thunar-vcs-plugin.install
deleted file mode 100644
index 9cb7ab6b45e7..000000000000
--- a/thunar-vcs-plugin.install
+++ /dev/null
@@ -1,3 +0,0 @@
-post_install() {
- gtk-update-icon-cache -f /usr/share/icons/hicolor
-}