summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD34
2 files changed, 39 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fa9d3a66314e..59cc49564820 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,24 @@
pkgbase = thunderbird-nightly-it
- pkgdesc = Standalone Mail/News reader - Nightly build (it)
pkgver = 80.0a1
pkgrel = 1
url = http://www.mozilla.org/it/thunderbird
- install = thunderbird-nightly-it.install
arch = i686
arch = x86_64
license = MPL
license = GPL
license = LGPL
+ source = https://download-installer.cdn.mozilla.net/pub/thunderbird/nightly/latest-comm-central/thunderbird-80.0a1.en-US.linux-x86_64.txt
+ source = https://download-installer.cdn.mozilla.net/pub/thunderbird/nightly/latest-comm-central-l10n/thunderbird-80.0a1.it.linux-x86_64.tar.bz2
+ source = thunderbird-nightly-it.desktop
+ source = vendor.js
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = 4f885cc6a2867db6864ade4f953bf743ebd779cc7fec8335aa60176c3c90306525b987c966f6f18484d07c131a88878306d037cc17207a0d01b198ccbc79852b
+ sha512sums = aeb444784732267f1b1e87e6084a776f82a1912c4c2637d2cf1de1c135dd9d41d2ef66d2bd3f9cbd3a79fad32d17ea6e2968ba644d5f887cb66ba6c09a2098f5
+
+pkgname = thunderbird-nightly-it
+ pkgdesc = Standalone Mail/News reader - Nightly build (it)
+ install = thunderbird-nightly-it.install
depends = alsa-lib
depends = cairo
depends = dbus-glib
@@ -30,16 +40,12 @@ pkgbase = thunderbird-nightly-it
depends = shared-mime-info
depends = sqlite
depends = startup-notification
- optdepends = libcanberra: for sound support
+ optdepends = libcanberra: per supporto audio
provides = thunderbird=80.0a1
- source = https://download-installer.cdn.mozilla.net/pub/thunderbird/nightly/latest-comm-central/thunderbird-80.0a1.en-US.linux-x86_64.txt
- source = https://download-installer.cdn.mozilla.net/pub/thunderbird/nightly/latest-comm-central-l10n/thunderbird-80.0a1.it.linux-x86_64.tar.bz2
- source = thunderbird-nightly-it.desktop
- source = vendor.js
- sha512sums = SKIP
- sha512sums = SKIP
- sha512sums = 4f885cc6a2867db6864ade4f953bf743ebd779cc7fec8335aa60176c3c90306525b987c966f6f18484d07c131a88878306d037cc17207a0d01b198ccbc79852b
- sha512sums = aeb444784732267f1b1e87e6084a776f82a1912c4c2637d2cf1de1c135dd9d41d2ef66d2bd3f9cbd3a79fad32d17ea6e2968ba644d5f887cb66ba6c09a2098f5
+ provides = thunderbird-nightly
+ conflicts = thunderbird-nightly
-pkgname = thunderbird-nightly-it
+pkgname = thunderbird-nightly-it-noupdate
+ pkgdesc = Standalone Mail/News reader - Nightly build (it) con notifiche di aggiornamento disabilitate
+ depends = thunderbird-nightly-it
diff --git a/PKGBUILD b/PKGBUILD
index 32a53ea50429..2b5f18bba07e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,18 @@
# Contributor: Frederik Schwan <frederik dot schwan at linux dot com>
# Contributor: Cedric Girard <girard.cedric@gmail.com>
# Contributor: Det <nimetonmaili at gmail a-dot com>
-# Based on AUR's thunderbird-nightly
+# Based on AUR's thunderbird-nightly-bin
_name=thunderbird
_channel=nightly
_lang=it
-pkgname=${_name}-${_channel}-${_lang}
+pkgname=(${_name}-${_channel}-${_lang} ${_name}-${_channel}-${_lang}-noupdate)
pkgver=80.0a1
_version=80.0a1
pkgrel=1
-pkgdesc="Standalone Mail/News reader - Nightly build (${_lang})"
arch=('i686' 'x86_64')
url="http://www.mozilla.org/it/thunderbird"
license=('MPL' 'GPL' 'LGPL')
-depends=('alsa-lib' 'cairo' 'dbus-glib' 'desktop-file-utils' 'fontconfig'
- 'freetype2' 'gtk3' 'hicolor-icon-theme' 'hunspell' 'libevent' 'libjpeg'
- 'libmng' 'libpng' 'libvpx' 'libxt' 'mozilla-common' 'nspr' 'nss'
- 'shared-mime-info' 'sqlite' 'startup-notification')
-optdepends=('libcanberra: per supporto audio')
-provides=("thunderbird=${_version}")
-install="${pkgname}.install"
FX_SRC_EN="${_name}-${_version}.en-US.linux-${CARCH}"
FX_SRC_URI_EN="https://download-installer.cdn.mozilla.net/pub/${_name}/${_channel}/latest-comm-central/${FX_SRC_EN}"
@@ -30,8 +22,8 @@ FX_SRC_URI="https://download-installer.cdn.mozilla.net/pub/${_name}/${_channel}/
source=("${FX_SRC_URI_EN}.txt"
"${FX_SRC_URI}.tar.bz2"
- "$pkgname.desktop"
- "vendor.js")
+ "${pkgname}.desktop"
+ vendor.js)
sha512sums=('SKIP'
'SKIP'
@@ -42,7 +34,17 @@ pkgver(){
echo "${_version}.$(head -n1 "${FX_SRC_EN}.txt" |cut -c -8)"
}
-package() {
+package_thunderbird-nightly-it() {
+ pkgdesc="Standalone Mail/News reader - Nightly build (${_lang})"
+ depends=('alsa-lib' 'cairo' 'dbus-glib' 'desktop-file-utils' 'fontconfig'
+ 'freetype2' 'gtk3' 'hicolor-icon-theme' 'hunspell' 'libevent' 'libjpeg'
+ 'libmng' 'libpng' 'libvpx' 'libxt' 'mozilla-common' 'nspr' 'nss'
+ 'shared-mime-info' 'sqlite' 'startup-notification')
+ optdepends=('libcanberra: per supporto audio')
+ provides=("thunderbird=${_version}" 'thunderbird-nightly')
+ conflicts=('thunderbird-nightly')
+ install="${pkgname}.install"
+
install -d "${pkgdir}"/{usr/bin,opt}
cp -a thunderbird "${pkgdir}"/opt/${pkgname}-${pkgver}
cp vendor.js "${pkgdir}"/opt/${pkgname}-${pkgver}/defaults/pref/
@@ -54,3 +56,9 @@ package() {
rm -rf "${pkgdir}"/opt/${pkgname}-${pkgver}/dictionaries/
ln -sf /usr/share/hunspell/ "${pkgdir}"/opt/${pkgname}-${pkgver}/dictionaries
}
+
+package_thunderbird-nightly-it-noupdate() {
+ pkgdesc="Standalone Mail/News reader - Nightly build (${_lang}) con notifiche di aggiornamento disabilitate"
+ depends=('thunderbird-nightly-it')
+ install -Dm644 -t "${pkgdir}"/opt/${pkgname-noupdate}-${pkgver}/distribution policies.json
+}