summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.AURINFO15
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD62
3 files changed, 93 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..e5d240d38771
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,15 @@
+pkgbase = tidyview
+ pkgdesc = Preview the effect of perltidy options on your source code
+ pkgver = 1.14
+ pkgrel = 1
+ url = http://sourceforge.net/projects/tidyview/
+ arch = any
+ license = GPL
+ makedepends = perl-log-log4perl
+ makedepends = perl-tk
+ depends = perl-tk-difftext
+ source = tidyview-1.14.tar.gz::http://downloads.sourceforge.net/project/tidyview/tidyview/tidyview-1.14/tidyview-1.14.tar.gz
+ options = !emptydirs
+
+pkgname = tidyview
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a3ca496ddaf0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = tidyview
+ pkgdesc = Preview the effect of perltidy options on your source code
+ pkgver = 1.14
+ pkgrel = 1
+ url = http://sourceforge.net/projects/tidyview/
+ arch = any
+ license = GPL
+ makedepends = perl-log-log4perl
+ makedepends = perl-tk
+ depends = perl-tk-difftext
+ options = !emptydirs
+ source = tidyview-1.14.tar.gz::http://downloads.sourceforge.net/project/tidyview/tidyview/tidyview-1.14/tidyview-1.14.tar.gz
+ sha256sums = 3cc0a7c8b662063a13de87cbfb3d5156751928aeb2c1aae35ad38bb8091febaf
+
+pkgname = tidyview
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7e8b72e6caab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# vim:set ts=2 sw=2 et ft=sh tw=100: expandtab
+# Maintainer: Piotr Rogoża <piotr dot r dot public at gmail dot com>
+# Contributor: Piotr Rogoża <piotr dot r dot public at gmail dot com>
+
+pkgname=tidyview
+pkgver=1.14
+pkgrel=1
+pkgdesc='Preview the effect of perltidy options on your source code'
+arch=('any')
+url='http://sourceforge.net/projects/tidyview/'
+license=('GPL')
+depends=(perl-tk-difftext)
+makedepends=(perl-log-log4perl perl-tk)
+options=(!emptydirs)
+source=("$pkgname-$pkgver.tar.gz::http://downloads.sourceforge.net/project/tidyview/tidyview/tidyview-${pkgver}/tidyview-${pkgver}.tar.gz")
+
+build(){
+ cd "$srcdir"/$pkgname-$pkgver
+
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ /usr/bin/perl Makefile.PL
+ make
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ /usr/bin/perl Build.PL
+ perl Build
+ fi
+}
+check(){
+ cd "$srcdir"/$pkgname-$pkgver
+ return
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ make test
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ perl Build test
+ fi
+}
+package(){
+ cd "$srcdir"/$pkgname-$pkgver
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ make install
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ perl Build install
+ fi
+
+ # remove perllocal.pod and .packlist
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+sha256sums=('3cc0a7c8b662063a13de87cbfb3d5156751928aeb2c1aae35ad38bb8091febaf')