summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
-rw-r--r--tjmc-launcher.sh4
3 files changed, 24 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 61677a054f46..fa9fe4caaf76 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,21 @@
pkgbase = tjmc-launcher-bin
pkgdesc = A simple to use, extremely fast, and well supported app, that allows you to install pure and modded versions of Java Minecraft.
- pkgver = 0.2.7
- pkgrel = 4
+ pkgver = 0.2.10
+ pkgrel = 1
url = https://launcher.tjmc.ru/
arch = aarch64
arch = x86_64
license = MIT
depends = electron23
- provides = tjmc-launcher=0.2.7
+ provides = tjmc-launcher=0.2.10
conflicts = tjmc-launcher
- source = LICENSE-0.2.7::https://raw.githubusercontent.com/tjmcraft/TJMC-Launcher/v0.2.7/LICENSE
+ source = LICENSE-0.2.10::https://raw.githubusercontent.com/tjmcraft/TJMC-Launcher/v0.2.10/LICENSE
source = tjmc-launcher.sh
sha256sums = 1a25e3b0f4bf16543e5f802cf6d9d189bcae27617ca8be936ad866a8955d9ce6
- sha256sums = 41b6d61dffef064762b3eec3dfeca7a3e1f57cbcb6dce9a6940c06797a0eae9d
- source_aarch64 = tjmc-launcher-0.2.7-aarch64.deb::https://github.com/tjmcraft/TJMC-Launcher/releases/download/v0.2.7/TJMC-Launcher-setup-arm64.deb
- sha256sums_aarch64 = 56b47b4d68367661f3e0b6a42b96c916b091908b420158e5b3d0df1e04941358
- source_x86_64 = tjmc-launcher-0.2.7-x86_64.deb::https://github.com/tjmcraft/TJMC-Launcher/releases/download/v0.2.7/TJMC-Launcher-setup-amd64.deb
- sha256sums_x86_64 = b4a0666c537e9e172748d785196a8d99698244ba25d9dffc5c0f55375a188ce9
+ sha256sums = 2b2e8aeed33fd71c521e49fd54fb2fa81218d16aef8bccb88d77909055ab8051
+ source_aarch64 = tjmc-launcher-0.2.10-aarch64.AppImage::https://github.com/tjmcraft/TJMC-Launcher/releases/download/v0.2.10/TJMC-Launcher-setup-arm64.AppImage
+ sha256sums_aarch64 = 768fca770466025a7d478ea4ccb06451203db87a21542e80aa2bbe474ea98a3f
+ source_x86_64 = tjmc-launcher-0.2.10-x86_64.AppImage::https://github.com/tjmcraft/TJMC-Launcher/releases/download/v0.2.10/TJMC-Launcher-setup-x86_64.AppImage
+ sha256sums_x86_64 = 140c56f94e27f78c230b63bb39b1c44492a21203749b601d31f453b84c4ceced
pkgname = tjmc-launcher-bin
diff --git a/PKGBUILD b/PKGBUILD
index c3de50f660c3..6836bdbfea6a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=tjmc-launcher-bin
_pkgname=TJMC-Launcher
-pkgver=0.2.7
+pkgver=0.2.10
_electronversion=23
-pkgrel=4
+pkgrel=1
pkgdesc="A simple to use, extremely fast, and well supported app, that allows you to install pure and modded versions of Java Minecraft."
arch=(
'aarch64'
@@ -17,16 +17,16 @@ conflicts=("${pkgname%-bin}")
depends=(
"electron${_electronversion}"
)
-source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.deb::${_ghurl}/releases/download/v${pkgver}/${_pkgname}-setup-arm64.deb")
-source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.deb::${_ghurl}/releases/download/v${pkgver}/${_pkgname}-setup-amd64.deb")
+source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.AppImage::${_ghurl}/releases/download/v${pkgver}/${_pkgname}-setup-arm64.AppImage")
+source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.AppImage::${_ghurl}/releases/download/v${pkgver}/${_pkgname}-setup-x86_64.AppImage")
source=(
"LICENSE-${pkgver}::https://raw.githubusercontent.com/tjmcraft/TJMC-Launcher/v${pkgver}/LICENSE"
"${pkgname%-bin}.sh"
)
sha256sums=('1a25e3b0f4bf16543e5f802cf6d9d189bcae27617ca8be936ad866a8955d9ce6'
- '41b6d61dffef064762b3eec3dfeca7a3e1f57cbcb6dce9a6940c06797a0eae9d')
-sha256sums_aarch64=('56b47b4d68367661f3e0b6a42b96c916b091908b420158e5b3d0df1e04941358')
-sha256sums_x86_64=('b4a0666c537e9e172748d785196a8d99698244ba25d9dffc5c0f55375a188ce9')
+ '2b2e8aeed33fd71c521e49fd54fb2fa81218d16aef8bccb88d77909055ab8051')
+sha256sums_aarch64=('768fca770466025a7d478ea4ccb06451203db87a21542e80aa2bbe474ea98a3f')
+sha256sums_x86_64=('140c56f94e27f78c230b63bb39b1c44492a21203749b601d31f453b84c4ceced')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
@@ -34,15 +34,16 @@ build() {
-e "s|@cfgdirname@|${pkgname%-bin}|g" \
-e "s|@options@||g" \
-i "${srcdir}/${pkgname%-bin}.sh"
- bsdtar -xf "${srcdir}/data."*
- sed "s|/opt/${_pkgname}/${pkgname%-bin}|${pkgname%-bin}|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
+ chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}-${CARCH}.AppImage"
+ "${srcdir}/${pkgname%-bin}-${pkgver}-${CARCH}.AppImage" --appimage-extract > /dev/null
+ sed "s|AppRun --no-sandbox|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
- install -Dm644 "${srcdir}/opt/${_pkgname}/resources/app.asar" -t "${pkgdir}/usr/lib/${pkgname%-bin}"
- install -Dm644 "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
+ install -Dm644 "${srcdir}/squashfs-root/resources/app.asar" -t "${pkgdir}/usr/lib/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/squashfs-root/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
for _icons in 16x16 32x32 48x48 64x64 128x128 256x256 512x512;do
- install -Dm644 "${srcdir}/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png" \
+ install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png" \
-t "${pkgdir}/usr/share/icons/hicolor/${_icons}/apps"
done
install -Dm644 "${srcdir}/LICENSE-${pkgver}" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
diff --git a/tjmc-launcher.sh b/tjmc-launcher.sh
index 398398461fee..4cfe3ac09dd8 100644
--- a/tjmc-launcher.sh
+++ b/tjmc-launcher.sh
@@ -23,7 +23,7 @@ if [[ -f "${_FLAGS_FILE}" ]]; then
fi
cd "${_APPDIR}"
if [[ "${EUID}" -ne 0 ]] || [[ "${ELECTRON_RUN_AS_NODE}" ]]; then
- exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "${_USER_FLAGS[@]}" "$@"
+ exec electron@electronversion@ "${_RUNNAME}" ${_OPTIONS} "${_USER_FLAGS[@]}" "$@"
else
- exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "${_USER_FLAGS[@]}" "$@"
+ exec electron@electronversion@ "${_RUNNAME}" ${_OPTIONS} --no-sandbox "${_USER_FLAGS[@]}" "$@"
fi \ No newline at end of file