summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD35
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..159958123a1d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = tkblt
+ pkgdesc = Adds a new command (vector) and widgets (graph and barchart) to the Tcl interpreter.
+ pkgver = 3.2.23
+ pkgrel = 1
+ url = https://github.com/wjoye/tkblt
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = tk
+ conflicts = blt_tcl85
+ conflicts = blt
+ source = tkblt-3.2.23.zip::https://github.com/wjoye/tkblt/archive/V3.2.23.zip
+ sha256sums = 66b14c32eebf2c7289b49cbb555fa24d83980516719fe24a3166bc78e693759f
+
+pkgname = tkblt
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..23b22af79b14
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+pkgname=tkblt
+pkgver=3.2.23
+pkgrel=1
+pkgdesc="Adds a new command (vector) and widgets (graph and barchart) to the Tcl interpreter."
+url="https://github.com/wjoye/tkblt"
+license=("BSD")
+depends=('tk')
+conflicts=('blt_tcl85' 'blt')
+arch=('i686' 'x86_64')
+source=("${pkgname}-${pkgver}.zip::https://github.com/wjoye/tkblt/archive/V${pkgver}.zip")
+sha256sums=('66b14c32eebf2c7289b49cbb555fa24d83980516719fe24a3166bc78e693759f')
+
+build() {
+ # configure
+ cd ${srcdir}/${pkgname}-${pkgver}
+
+ ./configure \
+ --prefix=/usr \
+ --with-tcl=/usr/lib \
+ --with-x --x-includes=/usr/include \
+ --x-libraries=/usr/lib \
+ --mandir=/usr/share/man
+
+ # Compile
+ make
+}
+
+package() {
+ # Fix for the man directory
+ mkdir -p ${pkgdir}/usr/share/man
+
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make -j 1 DESTDIR=${pkgdir} install
+ rm ${pkgdir}/usr/lib/tkbltConfig.sh
+}