summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.AURINFO14
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD35
3 files changed, 64 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..7cfc7ce85288
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,14 @@
+pkgbase = tmenu-git
+ pkgdesc = Fuzzy completion for anything in the terminal, like dmenu.
+ pkgver = 20140614
+ pkgrel = 1
+ url = https://github.com/dhamidi/tmenu
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = glibc
+ source = git+https://github.com/dhamidi/tmenu
+
+pkgname = tmenu-git
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e4f834d255ad
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = tmenu-git
+ pkgdesc = Fuzzy completion for anything in the terminal, like dmenu.
+ pkgver = 20140614
+ pkgrel = 1
+ url = https://github.com/dhamidi/tmenu
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = glibc
+ source = git+https://github.com/dhamidi/tmenu
+ md5sums = SKIP
+
+pkgname = tmenu-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e4e11ee15d4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Kyle Keen <keenerd@gmail.com>
+
+pkgname=tmenu-git
+pkgver=20140614
+pkgrel=1
+pkgdesc="Fuzzy completion for anything in the terminal, like dmenu."
+arch=('i686' 'x86_64')
+url="https://github.com/dhamidi/tmenu"
+license=('GPL3')
+depends=('glibc')
+makedepends=('git')
+source=("git+https://github.com/dhamidi/tmenu")
+md5sums=('SKIP')
+
+_gitname="tmenu"
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ git show -s --format="%ci" HEAD | sed -e 's/-//g' -e 's/ .*//'
+}
+
+build() {
+ cd "$srcdir/$_gitname"
+ #./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ # ignores DESTDIR, abuse prefix instead
+ make PREFIX="$pkgdir/usr/" install
+
+}
+
+# vim:set ts=2 sw=2 et: