summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD33
2 files changed, 29 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 17c2b5a2a0c9..f8e49b05c000 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,21 @@
pkgbase = tmsu
pkgdesc = A tool for tagging your files and accessing them through a virtual filesystem.
pkgver = 0.7.5
- pkgrel = 1
+ pkgrel = 2
url = https://tmsu.org/
arch = i686
arch = x86_64
license = GPL3
- makedepends = git
makedepends = go
- depends = fuse
+ depends = fuse2
depends = sqlite>=3
- provides = tmsu
source = tmsu-0.7.5.tar.gz::https://github.com/oniony/TMSU/archive/v0.7.5.tar.gz
+ source = 0001-tmsu-structure.patch::https://github.com/oniony/TMSU/commit/0beb23187d14a48f217f8ede2981cb5eaf6d89f2.patch
+ source = 0002-tmsu-go-files.patch::https://github.com/oniony/TMSU/commit/66a9facdacb48e1f81bb8a854f70485e3a361e59.patch
+ source = 0003-tmsu-makefile.patch::https://github.com/oniony/TMSU/commit/b10338e9136e35cbbd9ac4ebcf7d366f3a1b4a9e.patch
sha256sums = 0ac7f09336aaedf73623c4f486c05137c024a726c16dd32525463aee9d70b46a
+ sha256sums = c6e19521d7ba204193701507c7267f0bdd1e413f128205c57c34af279212a502
+ sha256sums = 914404ff4ce9e1afdf4a420d44734d2e4caf760d120bba41f2722b6ff57218e0
+ sha256sums = 267f40a0379491bc10327a498daaf0b2bda3cb616efa484ec26f5601145126fd
pkgname = tmsu
-
diff --git a/PKGBUILD b/PKGBUILD
index ee08a805bcef..575f52773417 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,25 +4,34 @@
pkgname=tmsu
pkgver=0.7.5
-pkgrel=1
+pkgrel=2
pkgdesc="A tool for tagging your files and accessing them through a virtual filesystem."
arch=('i686' 'x86_64')
url="https://tmsu.org/"
-depends=('fuse' 'sqlite>=3')
-makedepends=('git' 'go')
-provides=('tmsu')
+depends=('fuse2' 'sqlite>=3')
+makedepends=('go')
license=('GPL3')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/oniony/TMSU/archive/v$pkgver.tar.gz")
-sha256sums=('0ac7f09336aaedf73623c4f486c05137c024a726c16dd32525463aee9d70b46a')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/oniony/TMSU/archive/v$pkgver.tar.gz"
+ 0001-${pkgname}-structure.patch::https://github.com/oniony/TMSU/commit/0beb23187d14a48f217f8ede2981cb5eaf6d89f2.patch
+ 0002-${pkgname}-go-files.patch::https://github.com/oniony/TMSU/commit/66a9facdacb48e1f81bb8a854f70485e3a361e59.patch
+ 0003-${pkgname}-makefile.patch::https://github.com/oniony/TMSU/commit/b10338e9136e35cbbd9ac4ebcf7d366f3a1b4a9e.patch)
+sha256sums=('0ac7f09336aaedf73623c4f486c05137c024a726c16dd32525463aee9d70b46a'
+ 'c6e19521d7ba204193701507c7267f0bdd1e413f128205c57c34af279212a502'
+ '914404ff4ce9e1afdf4a420d44734d2e4caf760d120bba41f2722b6ff57218e0'
+ '267f40a0379491bc10327a498daaf0b2bda3cb616efa484ec26f5601145126fd')
-build() {
- export GOPATH=/tmp
+prepare() {
+ cd "TMSU-$pkgver"
- echo "Now getting go-sqlite3..."
- go get -u github.com/mattn/go-sqlite3
+ # Add upstream patches as the latest release has a wrong project structure
+ # and cannot be compiled with recent go versions
+ patch -Np1 -i ${srcdir}/0001-${pkgname}-structure.patch
+ patch -Np1 -i ${srcdir}/0002-${pkgname}-go-files.patch
+ patch -Np1 -i ${srcdir}/0003-${pkgname}-makefile.patch
+}
- echo "Now getting go-fuse..."
- go get -u github.com/hanwen/go-fuse/fuse
+build() {
+ export GOPATH=/tmp
cd "$srcdir/TMSU-$pkgver"
make