summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD44
2 files changed, 37 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 74db2605c96a..0f09c9c6327a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,24 @@
pkgbase = toggle-git
- pkgdesc = Like Tweaks, but with more libadwaita!
- pkgver = r101.4eda274
+ pkgdesc = Like Tweaks, but with more Libadwaita!
+ pkgver = r126.93f9333
pkgrel = 1
- url = https://gitlab.com/OroWith2Os/toggle
+ url = https://gitlab.gnome.org/World/toggle
arch = any
+ groups = modified
license = GPL3
checkdepends = appstream-glib
makedepends = blueprint-compiler
makedepends = git
makedepends = meson
+ makedepends = setconf
makedepends = typescript
- depends = libadwaita
depends = gjs
- depends = gnome-shell
- source = git+https://gitlab.com/OroWith2Os/toggle
- source = git+https://gitlab.gnome.org/BrainBlasted/gi-typescript-definitions
+ depends = libadwaita
+ optdepends = gnome-shell-extensions: enable Light Theme
+ provides = toggle
+ conflicts = toggle
+ source = git+https://gitlab.gnome.org/World/toggle.git
+ source = git+https://gitlab.gnome.org/BrainBlasted/gi-typescript-definitions.git
source = fix-build.patch
b2sums = SKIP
b2sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 2b0db289de7e..931e2b3db445 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,29 @@
-_name=toggle
+# https://aur.archlinux.org/packages/toggle-git
+groups=('modified')
+
pkgname=toggle-git
-pkgver=r101.4eda274
+_app_id=app.drey.Toggle
+pkgver=r126.93f9333
pkgrel=1
-pkgdesc="Like Tweaks, but with more libadwaita!"
+pkgdesc="Like Tweaks, but with more Libadwaita!"
arch=('any')
-url="https://gitlab.com/OroWith2Os/$_name"
+url="https://gitlab.gnome.org/World/toggle"
license=('GPL3')
-depends=('libadwaita' 'gjs' 'gnome-shell')
-makedepends=('blueprint-compiler' 'git' 'meson' 'typescript')
+depends=('gjs' 'libadwaita')
+makedepends=('blueprint-compiler' 'git' 'meson' 'setconf' 'typescript')
checkdepends=('appstream-glib')
-source=("git+https://gitlab.com/OroWith2Os/$_name"
- "git+https://gitlab.gnome.org/BrainBlasted/gi-typescript-definitions"
- "fix-build.patch")
+optdepends=('gnome-shell-extensions: enable Light Theme')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('git+https://gitlab.gnome.org/World/toggle.git'
+ 'git+https://gitlab.gnome.org/BrainBlasted/gi-typescript-definitions.git'
+ 'fix-build.patch')
b2sums=('SKIP'
- 'SKIP'
- 'e8f69a7f9e789251ef7e5060e1c681bbc1806371021f3bc1abf66fadb4dd48535c9e270cf9bf64beb9b6d67d469bc1c92526f9cec81baa2ac50e0862d53c2215')
+ 'SKIP'
+ 'e8f69a7f9e789251ef7e5060e1c681bbc1806371021f3bc1abf66fadb4dd48535c9e270cf9bf64beb9b6d67d469bc1c92526f9cec81baa2ac50e0862d53c2215')
pkgver() {
- cd "$_name"
+ cd "${pkgname%-git}"
( set -o pipefail
git describe --long --abbrev=7 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
@@ -25,18 +31,20 @@ pkgver() {
}
prepare() {
- cd $_name
+ cd "${pkgname%-git}"
git submodule init
git config submodule.src/gi-types.url "$srcdir/gi-typescript-definitions"
git -c protocol.file.allow=always submodule update
- patch --forward --strip=1 --input="${srcdir}/fix-build.patch"
-}
+ patch --forward --strip=1 --input="$srcdir/fix-build.patch"
+
+ # Correct Exec
+ setconf "data/${_app_id}.desktop.in.in" Exec "${pkgname%-git}"
+}
build() {
- cd $_name
- arch-meson ../$_name ../build
- meson compile -C ../build
+ arch-meson "${pkgname%-git}" build
+ meson compile -C build
}
check() {