summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD31
-rw-r--r--topcoder-arena2
-rw-r--r--topcoder.install11
4 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..07287afa0c04
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = topcoder-arena
+ pkgdesc = TopCoder Arena
+ pkgver = 1
+ pkgrel = 5
+ url = http://community.topcoder.com/tc
+ install = topcoder.install
+ arch = i686
+ arch = x86_64
+ license = custom:unknown
+ depends = java-runtime
+ noextract = KawigiEdit.jar
+ source = http://www.topcoder.com/contest/arena/ContestAppletProd.jnlp
+ source = http://community.topcoder.com/contest/classes/KawigiEdit/KawigiEdit.jar
+ source = topcoder-arena
+ md5sums = fadd41b6db7722df8dbd59d07ed198a5
+ md5sums = eb26a5e1b7a72d79a5f1a10bd71bcad2
+ md5sums = dfea72c31a518992dc0b64338468dafa
+
+pkgname = topcoder-arena
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2829581b7a99
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Thiago Perrotta <perrotta dot thiago at poli dot ufrj dot br>
+
+pkgname=topcoder-arena
+pkgver=1
+pkgrel=5
+pkgdesc='TopCoder Arena'
+arch=('i686' 'x86_64')
+url='http://community.topcoder.com/tc'
+license=('custom:unknown')
+depends=('java-runtime')
+source=('http://www.topcoder.com/contest/arena/ContestAppletProd.jnlp'
+ 'http://community.topcoder.com/contest/classes/KawigiEdit/KawigiEdit.jar'
+ 'topcoder-arena'
+)
+md5sums=('fadd41b6db7722df8dbd59d07ed198a5'
+ 'eb26a5e1b7a72d79a5f1a10bd71bcad2'
+ 'dfea72c31a518992dc0b64338468dafa')
+noextract=('KawigiEdit.jar')
+install=topcoder.install
+
+package() {
+ cd "${srcdir}/"
+ install -Dm755 topcoder-arena "${pkgdir}/usr/bin/topcoder-arena"
+ install -Dm755 ContestAppletProd.jnlp "${pkgdir}/usr/share/java/${pkgname}/ContestAppletProd.jnlp"
+
+ # plugins
+ for file in *.jar
+ do
+ install -Dm755 "$file" "${pkgdir}/usr/share/java/${pkgname}/$file"
+ done
+}
diff --git a/topcoder-arena b/topcoder-arena
new file mode 100644
index 000000000000..80f29df31540
--- /dev/null
+++ b/topcoder-arena
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec "${JAVA_HOME}/bin/javaws" '/usr/share/java/topcoder-arena/ContestAppletProd.jnlp' "$@"
diff --git a/topcoder.install b/topcoder.install
new file mode 100644
index 000000000000..ea5b7d75103c
--- /dev/null
+++ b/topcoder.install
@@ -0,0 +1,11 @@
+post_install() {
+ echo "To integrate plug-ins with the arena, you should follow this"
+ echo "tutorial http://topblogcoder.com/tutorials/kawigiedit-tutorial/"
+ echo
+ echo "To get the entrypoints, see "
+ echo "http://community.topcoder.com/tc?module=Static&d1=applet&d2=plugins"
+}
+
+post_upgrade() {
+ post_install
+}