summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD21
2 files changed, 19 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 46a94a079c6a..27bc4809e146 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = toppler-git
pkgdesc = A reimplementation of the classic jump & run game "Nebulus"
pkgver = 1.3+8+r542.20220323.c8bf02b
- pkgrel = 3
+ pkgrel = 4
url = https://gitlab.com/roever/toppler/
arch = i686
arch = x86_64
@@ -13,6 +13,7 @@ pkgbase = toppler-git
makedepends = libpng
makedepends = povray
depends = gcc-libs
+ depends = glibc
depends = sdl2
depends = sdl2_mixer
depends = zlib
diff --git a/PKGBUILD b/PKGBUILD
index 1a901deed28c..3940a972b2d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,26 @@
_pkgname=toppler
pkgname="${_pkgname}-git"
pkgver=1.3+8+r542.20220323.c8bf02b
-pkgrel=3
+pkgrel=4
pkgdesc='A reimplementation of the classic jump & run game "Nebulus"'
arch=('i686' 'x86_64')
url="https://gitlab.com/roever/toppler/"
license=('GPL-3.0-or-later')
-depends=('gcc-libs' 'sdl2' 'sdl2_mixer' 'zlib')
-makedepends=('gettext' 'gimp' 'git' 'imagemagick' 'libpng' 'povray')
+depends=(
+ 'gcc-libs'
+ 'glibc'
+ 'sdl2'
+ 'sdl2_mixer'
+ 'zlib'
+)
+makedepends=(
+ 'gettext'
+ 'gimp'
+ 'git'
+ 'imagemagick'
+ 'libpng'
+ 'povray'
+)
optdepends=(
"${_pkgname}-upstream-levels: The upstream levels as individual missions that can be played individually, and files that can be loaded into the level editor."
)
@@ -34,7 +47,7 @@ prepare() {
cd "${srcdir}/${_pkgname}"
for _patch in "${srcdir}"/fix-for-gcc14.patch; do
- printf " > Applying patch $(basename "${_patch}") ..."
+ printf '%s\n' " > Applying patch $(basename "${_patch}") ..."
patch -Np1 --follow-symlinks -i "${_patch}"
done