summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD29
-rw-r--r--torrentv-bin.desktop10
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..29bd59448758
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = torrentv-bin
+ pkgdesc = Stream Torrents to your AppleTV/Roku/Chromecast
+ pkgver = 0.9.6
+ pkgrel = 1
+ url = http://torrentv.github.io/
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ depends = gconf
+ depends = nss
+ depends = libxtst
+ depends = alsa-lib
+ source = torrentv-bin.desktop
+ sha1sums = 167dd21bff7a803192cc7a7f98a0c0bd2f5e00d0
+ source_x86_64 = torrentv-x86_64.tar.gz::http://goo.gl/zZUOXk
+ sha1sums_x86_64 = b66190c64258fc8f13fae036842f9c46d4c770d1
+ source_i686 = torrentv-x86_64.tar.gz::http://goo.gl/vlVWHw
+ sha1sums_i686 = 630366626cacf74a48c91690ba869860bd6ad8ed
+
+pkgname = torrentv-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9d8883e435ad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: asm0dey <pavel.finkelshtein@gmail.com>
+pkgname=torrentv-bin
+pkgver=0.9.6
+pkgrel=1
+pkgdesc="Stream Torrents to your AppleTV/Roku/Chromecast"
+arch=('x86_64' 'i686')
+url="http://torrentv.github.io/"
+license=('GPL3')
+
+source=("$pkgname.desktop")
+sha1sums=('167dd21bff7a803192cc7a7f98a0c0bd2f5e00d0')
+
+source_x86_64=("torrentv-$CARCH.tar.gz::http://goo.gl/zZUOXk")
+sha1sums_x86_64=("b66190c64258fc8f13fae036842f9c46d4c770d1")
+
+source_i686=("torrentv-$CARCH.tar.gz::http://goo.gl/vlVWHw")
+sha1sums_i686=("630366626cacf74a48c91690ba869860bd6ad8ed")
+
+depends=('gconf' 'nss' 'libxtst' 'alsa-lib')
+
+package() {
+ cd "$srcdir/TorrenTV"
+ install -Dm644 "$srcdir/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm755 TorrenTV "$pkgdir/opt/torrentv/TorrenTV"
+ install -Dm644 nw.pak "$pkgdir/opt/torrentv/nw.pak"
+ install -Dm644 libffmpegsumo.so "$pkgdir/opt/torrentv/libffmpegsumo.so"
+}
+
+
diff --git a/torrentv-bin.desktop b/torrentv-bin.desktop
new file mode 100644
index 000000000000..96b2de2d3bb5
--- /dev/null
+++ b/torrentv-bin.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=TorrenTV
+Comment=Stream Torrents to your AppleTV/Roku/Chromecast
+Path=/opt/torrentv
+Exec=TorrenTV
+Icon=TorrenTV
+Terminal=false
+Categories=Video;AudioVideo;