summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD82
2 files changed, 79 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 907f1f2d6bd7..f439db08f5c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,37 +1,43 @@
pkgbase = totem-git
pkgdesc = Movie player for the GNOME desktop based on GStreamer
- pkgver = 43.0+r3+g040ca6f91
+ pkgver = 43.0+r127+gfa01f7dd2
pkgrel = 1
url = https://wiki.gnome.org/Apps/Videos
arch = x86_64
groups = gnome
+ groups = gnome-git
license = GPL2
license = custom
- makedepends = libnautilus-extension
- makedepends = itstool
+ checkdepends = xorg-server-xvfb
+ makedepends = appstream-glib
makedepends = docbook-xsl
- makedepends = python-pylint
- makedepends = gobject-introspection
+ makedepends = intltool
+ makedepends = itstool
makedepends = git
- makedepends = appstream-glib
+ makedepends = gobject-introspection
makedepends = gtk-doc
+ makedepends = libnautilus-extension
makedepends = meson
- makedepends = intltool
- depends = totem-plparser
- depends = iso-codes
- depends = libpeas
+ makedepends = python-pylint
+ makedepends = yelp-tools
+ depends = appstream-glib
depends = grilo
- depends = gsettings-desktop-schemas
- depends = python-gobject
depends = gnome-desktop
+ depends = gsettings-desktop-schemas
depends = gst-plugins-base
depends = gst-plugins-good
depends = gst-plugins-bad
depends = gst-plugin-gtk
+ depends = iso-codes
depends = libhandy
+ depends = libpeas
+ depends = libportal-gtk3
+ depends = python-gobject
+ depends = totem-plparser
optdepends = gst-plugins-ugly: Extra media codecs
optdepends = gst-libav: Extra media codecs
optdepends = grilo-plugins: Media discovery
+ provides = libtotem.so
provides = totem
conflicts = totem
conflicts = totem-plugin
diff --git a/PKGBUILD b/PKGBUILD
index 39b9df03ff19..b131aea07562 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,51 +1,91 @@
-# Maintainer: Francois Menning <f.menning@pm.me>
+# Maintainer: Pellegrino Prevete (tallero) <pellegrinoprevete@gmail.com>
+# Contributor: Francois Menning <f.menning@pm.me>
# Contributor: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
# Contributor: Jan de Groot <jgc@archlinux.org>
-pkgname=totem-git
-pkgver=43.0+r3+g040ca6f91
+_pkgname="totem"
+_group="gnome"
+pkgname="${_pkgname}-git"
+pkgver=43.0+r127+gfa01f7dd2
pkgrel=1
pkgdesc="Movie player for the GNOME desktop based on GStreamer"
-url="https://wiki.gnome.org/Apps/Videos"
+url="https://wiki.${_group}.org/Apps/Videos"
arch=(x86_64)
license=(GPL2 custom)
-depends=(totem-plparser iso-codes libpeas grilo gsettings-desktop-schemas
- python-gobject gnome-desktop gst-plugins-base gst-plugins-good
- gst-plugins-bad gst-plugin-gtk libhandy)
-makedepends=(libnautilus-extension itstool docbook-xsl python-pylint
- gobject-introspection git appstream-glib gtk-doc meson intltool)
+depends=(
+ appstream-glib
+ grilo
+ "${_group}-desktop"
+ gsettings-desktop-schemas
+ gst-plugins-base
+ gst-plugins-good
+ gst-plugins-bad
+ gst-plugin-gtk
+ iso-codes
+ libhandy
+ libpeas
+ libportal-gtk3
+ python-gobject
+ "${_pkgname}-plparser")
+makedepends=(
+ appstream-glib
+ docbook-xsl
+ intltool
+ itstool
+ git
+ gobject-introspection
+ gtk-doc
+ libnautilus-extension
+ meson
+ python-pylint
+ yelp-tools)
+checkdepends=(xorg-server-xvfb)
optdepends=('gst-plugins-ugly: Extra media codecs'
'gst-libav: Extra media codecs'
'grilo-plugins: Media discovery')
-conflicts=(totem totem-plugin)
-replaces=(totem-plugin)
-provides=(totem)
-groups=(gnome)
+provides=("lib${_pkgname}.so"
+ "${_pkgname}")
+conflicts=(
+ "${_pkgname}"
+ "${_pkgname}-plugin")
+replaces=("${_pkgname}-plugin")
+groups=("${_group}" "${_group}-git")
options=(debug)
-source=("git+https://gitlab.gnome.org/GNOME/totem.git"
- "git+https://gitlab.gnome.org/GNOME/libgd.git")
+_org_repo="https://gitlab.${_group}.org/GNOME"
+source=("git+${_org_repo}/${_pkgname}.git"
+ "git+${_org_repo}/libgd.git")
sha256sums=('SKIP'
'SKIP')
pkgver() {
- cd totem
+ cd "${_pkgname}"
git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
}
prepare() {
- cd totem
+ cd "${_pkgname}"
git submodule init
- git submodule set-url subprojects/libgd "$srcdir/libgd"
- git submodule update
+ git submodule set-url subprojects/libgd "${srcdir}/libgd"
+ git -c protocol.file.allow=always \
+ submodule update
}
build() {
- arch-meson totem build -D enable-gtk-doc=true
+ local meson_options=(
+ -D enable-gtk-doc=true
+ )
+ arch-meson "${_pkgname}" build "${meson_options[@]}"
meson compile -C build
}
+check() {
+ dbus-run-session xvfb-run -s '-nolisten local' \
+ meson test -C build --print-errorlogs
+}
+
package() {
meson install -C build --destdir "$pkgdir"
- install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 totem/COPYING
+ install -Dt "${pkgdir}/usr/share/licenses/${pkgname}" \
+ -m644 "${_pkgname}/COPYING"
}