summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d17fe651b88a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = touchtyper
+ pkgdesc = typing trainer - an application suite for training and exercising touchtyping
+ pkgver = 1.0rc2
+ pkgrel = 1
+ url = http://typingtrainer.sourceforge.net/
+ arch = i686
+ license = GPL-2
+ depends = kdelibs3
+ depends = hicolor-icon-theme
+ source = http://downloads.sourceforge.net/project/typingtrainer/touchtyper/1.0rc2/touchtyper-1.0rc2.tar.gz
+ md5sums = a979c193039b994b81e0553034f91115
+
+pkgname = touchtyper
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bcc633f52aa4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Contributor: Jozef Riha <jose1711 at gmail dot com>
+
+pkgname=touchtyper
+pkgver=1.0rc2
+pkgrel=1
+pkgdesc="typing trainer - an application suite for training and exercising touchtyping"
+url="http://typingtrainer.sourceforge.net/"
+arch=('i686')
+license=('GPL-2')
+depends=('kdelibs3' 'hicolor-icon-theme')
+source=("http://downloads.sourceforge.net/project/typingtrainer/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz")
+md5sums=('a979c193039b994b81e0553034f91115')
+
+build() {
+cd $srcdir/${pkgname}-1.0
+./configure --prefix=/usr --without-arts
+make || return 1
+make DESTDIR=${pkgdir} install || return 1
+}