summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD32
-rw-r--r--tox-weechat-git.install5
3 files changed, 18 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index feff6fbf9156..a3f225dbab16 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,19 @@
pkgbase = tox-weechat-git
pkgdesc = Tox protocol plugin for WeeChat
- pkgver = r260.210a644
+ pkgver = r348.424eacc
pkgrel = 1
- url = https://github.com/haavardp/tox-weechat
- install = tox-weechat-git.install
+ url = https://github.com/haavard/tox-weechat
arch = i686
arch = x86_64
license = GPL3
makedepends = git
makedepends = cmake
depends = toxcore
- depends = weechat>=1.0.1
+ depends = weechat
provides = tox-weechat
conflicts = tox-weechat
- source = tox-weechat-git::git+https://github.com/haavardp/tox-weechat.git
- md5sums = SKIP
+ source = tox-weechat-git::git+https://github.com/haavard/tox-weechat.git
+ sha256sums = SKIP
pkgname = tox-weechat-git
diff --git a/PKGBUILD b/PKGBUILD
index f22163de428d..cdb3272da40d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,36 @@
-# Maintainer: Johnathan Jenkins <twodopeshaggy@gmail.com>
+# Maintainer: physkets <physkets // at // tutanota dot com>
+# Contributor: Johnathan Jenkins <twodopeshaggy@gmail.com>
# Contributor: HÃ¥vard Pettersson <mail@haavard.me>
_pkgname=tox-weechat
-pkgname=tox-weechat-git
-pkgver=r260.210a644
+pkgname="${_pkgname}-git"
+pkgver=r348.424eacc
pkgrel=1
pkgdesc='Tox protocol plugin for WeeChat'
arch=('i686' 'x86_64')
-url='https://github.com/haavardp/tox-weechat'
+url="https://github.com/haavard/${_pkgname}"
license=('GPL3')
-
-depends=(
- 'toxcore'
- 'weechat>=1.0.1'
-)
+depends=('toxcore' 'weechat')
makedepends=('git' 'cmake')
-
provides=("${_pkgname}")
conflicts=("${_pkgname}")
-
-source=("${pkgname}::git+https://github.com/haavardp/tox-weechat.git")
-md5sums=('SKIP')
-
-install="${pkgname}.install"
+source=("${pkgname}::git+https://github.com/haavard/${_pkgname}.git")
+sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/${pkgname}"
+ cd "${pkgname}"
printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "${srcdir}/${pkgname}"
- cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ cd "${pkgname}"
+ mkdir build && cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
make
}
package() {
- cd "${srcdir}/${pkgname}"
+ cd "${pkgname}/build"
make DESTDIR="${pkgdir}/" install
}
diff --git a/tox-weechat-git.install b/tox-weechat-git.install
deleted file mode 100644
index 915c1a2983df..000000000000
--- a/tox-weechat-git.install
+++ /dev/null
@@ -1,5 +0,0 @@
-post_install() {
- echo "Load Tox-WeeChat in WeeChat manually with '/plugin load /usr/lib/weechat/plugins/tox.so'"
- echo 'It should load automatically.'
-}
-