summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD35
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..673f44e4ed39
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = toxfile-git
+ pkgdesc = Utilities for toxfiles.
+ pkgver = 43.650640c
+ pkgrel = 1
+ url = https://github.com/saneki/toxfile
+ arch = any
+ license = GPL-3.0
+ makedepends = git
+ depends = jansson
+ depends = toxcore
+ source = git://github.com/saneki/toxfile.git
+ sha256sums = SKIP
+
+pkgname = toxfile-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b319e8e43b4c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: saneki <s@neki.me>
+pkgname=toxfile-git
+_pkgname=toxfile
+pkgver=43.650640c
+pkgrel=1
+pkgdesc="Utilities for toxfiles."
+arch=("any")
+url="https://github.com/saneki/toxfile"
+license=("GPL-3.0")
+makedepends=(git)
+depends=(jansson toxcore)
+source=("git://github.com/saneki/${_pkgname}.git")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "${_pkgname}"
+ echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${_pkgname}"
+ git submodule update --init --recursive
+ TOXDUMP_SO_JANSSON=true make
+}
+
+package() {
+ # Install binaries
+ mkdir -p "${pkgdir}/usr/bin"
+ install -Dm0755 "${_pkgname}/toxdump" "${pkgdir}/usr/bin/"
+ install -Dm0755 "${_pkgname}/toxfile" "${pkgdir}/usr/bin/"
+ # Install man pages
+ mkdir -p "${pkgdir}/usr/share/man/man1"
+ gzip --stdout "${_pkgname}/man/toxdump.1" > "${pkgdir}/usr/share/man/man1/toxdump.1.gz"
+ gzip --stdout "${_pkgname}/man/toxfile.1" > "${pkgdir}/usr/share/man/man1/toxfile.1.gz"
+}