summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 47c336088e2a..d80dea9fcd2e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,6 +10,8 @@ pkgbase = translater-git
makedepends = git
makedepends = crystal
makedepends = shards
+ depends = firefox
+ depends = geckodriver
depends = glibc
depends = gc
depends = gcc-libs
@@ -19,8 +21,6 @@ pkgbase = translater-git
depends = pcre2
depends = zlib
optdepends = goldendict: Feature-rich dictionary lookup program supporting multiple dictionary formats
- optdepends = firefox: Standalone web browser from mozilla.org
- optdepends = geckodriver: Proxy for using W3C WebDriver-compatible clients to interact with Gecko-based browsers.
provides = translater
conflicts = translater
source = translater-git::git+https://github.com/crystal-china/translater.git
diff --git a/PKGBUILD b/PKGBUILD
index 0f96dba6b047..9a18751cb6fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,6 +13,8 @@ provides=(${pkgname%-git})
conflicts=(${pkgname%-git})
replaces=()
depends=(
+ firefox
+ geckodriver
glibc
gc
gcc-libs
@@ -24,9 +26,7 @@ depends=(
makedepends=(git
crystal
shards)
-optdepends=("goldendict: Feature-rich dictionary lookup program supporting multiple dictionary formats"
- "firefox: Standalone web browser from mozilla.org"
- "geckodriver: Proxy for using W3C WebDriver-compatible clients to interact with Gecko-based browsers.")
+optdepends=("goldendict: Feature-rich dictionary lookup program supporting multiple dictionary formats")
backup=()
options=()
install=
@@ -48,7 +48,7 @@ pkgver() {
build() {
cd "${srcdir}/${pkgname}"
export LDFLAGS+=" -Wl,-z,relro,-z,now -Wl,-z,shstk"
- make
+ make release
}
package() {