summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD25
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c72a491c32ca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = tremulous-data
+ pkgdesc = Shared data files for Tremulous
+ pkgver = 1.1.0
+ pkgrel = 2
+ url = http://tremulous.net/
+ arch = any
+ license = GPL
+ source = http://downloads.sourceforge.net/tremulous/tremulous-1.1.0.zip
+ md5sums = 3df5f7565571fb9524656308347bce1b
+
+pkgname = tremulous-data
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a08086a05792
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Contributor: Daenyth <Daenyth+Arch AT gmail DOT com>
+pkgname=tremulous-data
+pkgver=1.1.0
+pkgrel=2
+pkgdesc='Shared data files for Tremulous'
+arch=('any')
+url='http://tremulous.net/'
+license=('GPL')
+source=("http://downloads.sourceforge.net/tremulous/tremulous-$pkgver.zip")
+md5sums=('3df5f7565571fb9524656308347bce1b')
+
+prepare() {
+ # Remove unneeded files from game directory
+ rm tremulous/{CC,COPYING,ChangeLog,GPL,tremulous.{exe,x86,xpm},tremded.x86}
+
+ # Remove the sources
+ rm tremulous/tremulous-$pkgver-src.tar.gz
+}
+
+package() {
+ # Install game data
+ install -dm755 $pkgdir/opt/
+ cp -r tremulous/ $pkgdir/opt/
+ find $pkgdir -type f -exec chmod 644 {} +
+}