summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD6
-rw-r--r--trio-use-arch-flags.patch26
3 files changed, 35 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 67b35ee5fb67..5e889e95a77f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,16 @@
pkgbase = trio
pkgdesc = Portable string functions, focus on the *printf() and *scanf() clones
pkgver = 1.16
- pkgrel = 2
+ pkgrel = 3
url = https://sourceforge.net/projects/ctrio/
arch = x86_64
license = custom
+ depends = glibc
source = http://downloads.sourceforge.net/project/ctrio/trio/trio-1.16.tar.gz
+ source = trio-use-arch-flags.patch
source = trio-fix-install.patch
sha256sums = 84d0e74f5b25f0b6c7d9b264ef41f98908e65a5056d4e75c5ef0e05d6a69fc0a
+ sha256sums = 688b0873fde6d8746a5b879b1dc368985293aac0727679cdaf7e571227e78e7d
sha256sums = 727d780675109717b967ba4449861f573b3d43f56af97a59ca5ab08af38a99b4
pkgname = trio
diff --git a/PKGBUILD b/PKGBUILD
index 33e22928f548..51056be8f8e0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,23 @@
pkgname=trio
pkgver=1.16
-pkgrel=2
+pkgrel=3
pkgdesc='Portable string functions, focus on the *printf() and *scanf() clones'
arch=('x86_64')
url='https://sourceforge.net/projects/ctrio/'
license=('custom')
+depends=('glibc')
source=("http://downloads.sourceforge.net/project/ctrio/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+ 'trio-use-arch-flags.patch'
'trio-fix-install.patch')
sha256sums=('84d0e74f5b25f0b6c7d9b264ef41f98908e65a5056d4e75c5ef0e05d6a69fc0a'
+ '688b0873fde6d8746a5b879b1dc368985293aac0727679cdaf7e571227e78e7d'
'727d780675109717b967ba4449861f573b3d43f56af97a59ca5ab08af38a99b4')
prepare() {
cd "${pkgname}-${pkgver}"
+ patch -Np1 -i "${srcdir}/trio-use-arch-flags.patch"
patch -Np1 -i "${srcdir}/trio-fix-install.patch"
}
diff --git a/trio-use-arch-flags.patch b/trio-use-arch-flags.patch
new file mode 100644
index 000000000000..e9003ec1175b
--- /dev/null
+++ b/trio-use-arch-flags.patch
@@ -0,0 +1,26 @@
+diff -Naurp a/Makefile.in b/Makefile.in
+--- a/Makefile.in 2013-09-18 12:48:43.000000000 +0000
++++ b/Makefile.in 2019-06-01 20:21:06.204864658 +0000
+@@ -1,11 +1,11 @@
+ SHELL = @SHELL@
+ CC = @CC@
+-CFLAGS = @CFLAGS@ -I. -DDEBUG -fPIC -fvisibility=hidden
++CFLAGS = @CPPFLAGS@ @CFLAGS@ -I. -DDEBUG -fPIC -fvisibility=hidden
+ OBJS = triostr.o trio.o trionan.o
+ TARGETLIB = libtrio.a
+ TARGETSHLIB = $(TARGETLIB:.a=.so.2.0.0)
+ TARGETINCS = trio.h triop.h triodef.h trionan.h triostr.h
+-LDFLAGS = -L. -ltrio -lm
++LDFLAGS = @LDFLAGS@ -L. -ltrio -lm
+ AR = ar
+ RANLIB = @RANLIB@
+ ERASE = rm -f
+@@ -68,7 +68,7 @@ $(TARGETLIB): $(OBJS)
+ $(RANLIB) $(TARGETLIB)
+
+ $(TARGETSHLIB): $(TARGETLIB)
+- $(CC) -lm -shared -Wl,-soname,$(patsubst %.so.2.0.0,%.so.2,$@) -Wl,--whole-archive,$< -Wl,--no-whole-archive -o $@
++ $(CC) -lm -shared -Wl,-soname,$(patsubst %.so.2.0.0,%.so.2,$@) -Wl,--whole-archive,$< -Wl,--no-whole-archive -o $@ $(LDFLAGS)
+
+ doc::
+ (cd $(srcdir) && $(GENDOC) doc/trio.cfg)