summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2e3ce81418e8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = tt-rss-plugin-api-resize-git
+ pkgdesc = Allows TT-RSS API clients to request downscaled images
+ pkgver = r28.070d17c
+ pkgrel = 1
+ url = https://git.tt-rss.org/fox/ttrss-api-resize
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = tt-rss
+ depends = php-gd
+ provides = tt-rss-plugin-api-resize
+ conflicts = tt-rss-plugin-api-resize
+ source = tt-rss-plugin-api-resize::git+https://git.tt-rss.org/fox/ttrss-api-resize.git
+ md5sums = SKIP
+
+pkgname = tt-rss-plugin-api-resize-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2be1373f6f2a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: JSH <jsh6789@gmail.com>
+pkgname=tt-rss-plugin-api-resize-git
+pkgver=r28.070d17c
+pkgrel=1
+pkgdesc="Allows TT-RSS API clients to request downscaled images"
+arch=('any')
+url="https://git.tt-rss.org/fox/ttrss-api-resize"
+license=('GPL3')
+depends=('tt-rss' 'php-gd')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("${pkgname%-git}::git+${url}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ installdir="${pkgdir}/usr/share/webapps/tt-rss/plugins/api_resize_media"
+ install -m 755 -d "${installdir}"
+ cd "$srcdir/${pkgname%-git}"
+ cp -R * "${installdir}"
+ find "${installdir}" -type d -exec chmod 755 '{}' \; -type f -exec chmod 644 '{}' \;
+}