summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD22
-rw-r--r--ttf.install16
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ea6ece65a921
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ttf-antipasto
+ pkgdesc = Antipasto is a soft round font and really smart created by Cosimo Lorenzo Pancini. An Arista font collection by Zetafonts.
+ pkgver = 3
+ pkgrel = 1
+ url = http://www.zetafonts.com/collection/104/
+ install = ttf.install
+ arch = any
+ license = custom:free
+ depends = fontconfig
+ depends = xorg-fonts-encodings
+ depends = xorg-font-utils
+ source = http://www.fontsy.com/fonts/file/11552_antipasto.zip
+ md5sums = e62359a6a7288e925851a1d6d27ad6ff
+
+pkgname = ttf-antipasto
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..84037e4b3f0c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Mike Redd <mredd@0tue0.com>
+# Contributor: Mike Redd <mredd@0tue0.com>
+pkgname=ttf-antipasto
+_pkgname=antipasto
+pkgver=3
+pkgrel=1
+pkgdesc="Antipasto is a soft round font and really smart created by Cosimo Lorenzo Pancini. An Arista font collection by Zetafonts."
+arch=('any')
+license=('custom:free')
+url="http://www.zetafonts.com/collection/104/"
+depends=('fontconfig' 'xorg-fonts-encodings' 'xorg-font-utils')
+install=ttf.install
+source=("http://www.fontsy.com/fonts/file/11552_${_pkgname}.zip")
+
+md5sums=('e62359a6a7288e925851a1d6d27ad6ff')
+
+package() {
+ cd $srcdir
+ install -d $pkgdir/usr/share/fonts/TTF/
+ install -m644 *.ttf $pkgdir/usr/share/fonts/TTF/ || return 1
+ install -Dm644 README_* $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}
diff --git a/ttf.install b/ttf.install
new file mode 100644
index 000000000000..24b98c5f9b15
--- /dev/null
+++ b/ttf.install
@@ -0,0 +1,16 @@
+post_install() {
+ echo "Updating font cache... "
+ fc-cache -f > /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo " ...done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+