summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--40-ddc-uchen.conf12
-rw-r--r--90-tt-ddc-uchen.conf26
-rw-r--r--PKGBUILD35
5 files changed, 95 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f26236624d44
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ttf-ddc-uchen
+ pkgdesc = DDC Uchen is a font designed by Chris Fynn for the Dzongkha Development Commission.
+ pkgver = 1.000
+ pkgrel = 1
+ url = https://sites.google.com/site/chrisfynn2/home/fonts/ddc-uchen
+ arch = any
+ license = custom:OFL
+ depends = fontconfig
+ provides = ttf-ddc-uchen-ib
+ source = http://www.dzongkha.gov.bt/IT/download/fonts/DDC_Uchen.ttf
+ source = 40-ddc-uchen.conf
+ source = 90-tt-ddc-uchen.conf
+ sha1sums = 82b6129f846419503a69e969fbd442949fa949ba
+ sha1sums = 0d6041afb31037dc71bb4085c58cb0e30ce6da3e
+ sha1sums = 0baa6a003a18c67305e06757587faa17dabfa997
+
+pkgname = ttf-ddc-uchen
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..eee70bc42d21
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.ttf
+*.xz
+src*
+pkg*
diff --git a/40-ddc-uchen.conf b/40-ddc-uchen.conf
new file mode 100644
index 000000000000..8764ad01e5be
--- /dev/null
+++ b/40-ddc-uchen.conf
@@ -0,0 +1,12 @@
+<?xml version="1.0"?>
+<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
+<fontconfig>
+
+ <alias>
+ <family>DDC Uchen</family>
+ <default>
+ <family>serif</family>
+ </default>
+ </alias>
+
+</fontconfig> \ No newline at end of file
diff --git a/90-tt-ddc-uchen.conf b/90-tt-ddc-uchen.conf
new file mode 100644
index 000000000000..8259ab4f05a4
--- /dev/null
+++ b/90-tt-ddc-uchen.conf
@@ -0,0 +1,26 @@
+<?xml version='1.0'?>
+<!DOCTYPE fontconfig SYSTEM 'fonts.dtd'>
+<fontconfig>
+
+ <match target="font">
+ <test name="force_autohint">
+ <bool>false</bool>
+ </test>
+ <test name="family">
+ <string>DDC Uchen</string>
+ </test>
+ <edit name="antialias" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hinting" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hintstyle" mode="assign">
+ <const>hintslight</const>
+ </edit>
+ <edit name="autohint" mode="assign">
+ <bool>false</bool>
+ </edit>
+ </match>
+
+</fontconfig> \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..df68c211ffb1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Contributor: bohoomil <@zoho.com>
+# Maintainer: Jristz <prflr88 arro'a gmail puntocom>
+
+pkgname=ttf-ddc-uchen
+pkgver=1.000
+pkgrel=1
+depends=('fontconfig')
+pkgdesc="DDC Uchen is a font designed by Chris Fynn for the Dzongkha Development Commission."
+url="https://sites.google.com/site/chrisfynn2/home/fonts/ddc-uchen"
+arch=('any')
+provides=('ttf-ddc-uchen-ib')
+conficts=('ttf-ddc-uchen-ib')
+license=('custom:OFL')
+source=(http://www.dzongkha.gov.bt/IT/download/fonts/DDC_Uchen.ttf
+ 40-ddc-uchen.conf
+ 90-tt-ddc-uchen.conf)
+sha1sums=('82b6129f846419503a69e969fbd442949fa949ba'
+ '0d6041afb31037dc71bb4085c58cb0e30ce6da3e'
+ '0baa6a003a18c67305e06757587faa17dabfa997')
+
+package(){
+
+ install -m755 -d "${pkgdir}"/usr/share/fonts/TTF
+ install -m644 *.ttf "${pkgdir}"/usr/share/fonts/TTF/
+
+ install -D -m644 40-ddc-uchen.conf \
+ "${pkgdir}"/etc/fonts/conf.avail/40-ddc-uchen.conf
+ install -D -m644 90-tt-ddc-uchen.conf \
+ "${pkgdir}"/etc/fonts/conf.avail/90-tt-ddc-uchen.conf
+
+ install -m755 -d "${pkgdir}"/etc/fonts/conf.d
+ cd "${pkgdir}"/etc/fonts/conf.d
+ ln -s ../conf.avail/40-ddc-uchen.conf .
+ ln -s ../conf.avail/90-tt-ddc-uchen.conf .
+}